Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Problems with the ecommerce-Module


Reply


3 Posts   1249 Views

Avatar
severin.schols

Community Member, 1 Post

1 December 2007 at 11:05am

Hi
i'm working on a task for the Google Highly Open Participation Contest and i'm having some issues with the ecommerce-module, which i'm supposed to make translateable.
After trying to install the module, i get the following error:
Fatal error: Declaration of Order_Item::__construct() must be compatible with that of DataObjectInterface::__construct() in C:\xampplite\htdocs\silverstripe\ecommerce\code\Order.php on line 1088

any hints on what's the problem?

thanks
Severin

Avatar
perfectfool

Community Member, 3 Posts

15 March 2008 at 7:59am

Edited: 15/03/2008 8:01am

I'm getting the exact same issue with 2.2.2rc2 when trying to install ecommerce 0.5.1. Can this be fixed?

Avatar
perfectfool

Community Member, 3 Posts

17 March 2008 at 11:21pm

Bueller?