Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Upload Files - Actionscript error


Reply


8 Posts   3042 Views

Avatar
JasonT

Community Member, 5 Posts

3 December 2007 at 4:23pm

I've just started trying out Silverstripe and having a problem with uploading files, and receive a flash actionscript error

TypeError: Error #1009: Cannot access a property or method of a null object reference. at SWFUpload/::IOError_Handler()

PHP Version 5.1.4
Flash Player: 9,0,45,0
Server: Apache/Linux

I have tried using both Firefox and IE7 on different computers with the same result

Any suggestions are greatly appreciated

Avatar
JasonT

Community Member, 5 Posts

4 December 2007 at 11:35pm

I've upgraded to PHP 5.2.4 still no luck

Avatar
DaveP

Community Member, 48 Posts

5 December 2007 at 12:26am

Hi there,

Not sure if this helps, but I found that error mentioned on a forum ( nothing to do with SS )

And a reply stated it was a write permission issue.

regards, Dave Porter

Avatar
JasonT

Community Member, 5 Posts

5 December 2007 at 12:57am

Thanks for the suggestion

I probably should have mentioned, PHP5 is running as suexec , so dont need to set write permissions

I dont know if its normal, but when first loggin into admin, it takes a rather long time to load, once logged in its acceptable

Avatar
Sigurd

Forum Moderator, 628 Posts

5 December 2007 at 10:13am

Please provide...

- Flash version
- Browser and version
- Operating System and version

:)

It may be that you need to upgrade Flash, but I don't know enough from you to be confident with that suggestion :)

Avatar
JasonT

Community Member, 5 Posts

6 December 2007 at 2:43am

Flash Player: 9,0,45,0
OS: XP Pro SP2
Browser: Firefox 2.0.0.11, FireFox3 beta, IE7

I believe I have all the lastest updates

I have tested on 3 different computers

Avatar
Minh

Community Member, 5 Posts

6 December 2007 at 4:46am

Jason,

Check /tmp to see if the upload file is making it in there first. I would still try to chmod 777 the upload directory even though your running php through suexec.

Avatar
JasonT

Community Member, 5 Posts

7 December 2007 at 11:30am

Edited: 07/12/2007 11:31am

Appears the problem is only my (3) computers, had someone else try and all was ok.

Tried reinstalling flash still not working, the above flash player version was for Firefox, I have 9,0,115,0 installed for IE7