Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Internal Server Errors


Reply


8 Posts   9902 Views

Avatar
Peter Prins

Community Member, 8 Posts

10 December 2007 at 9:09am

I am still getting Internal Server Errors :( I have Silverstripe running on a GoDaddy Shared Linux Hosting Account with PHP 5.1.4 and MySQL 4.1. I think it has something to do with the PHP5 Memory Limit I'm not sure if GoDaddy is allowing the memory_limit to be changed. How can I determine if this is the case? And is there a way I can improve the performance of Silverstripe to fix this? Also why does Silverstripe have a higher memory limit than say Drupal for example?

This is my php5.ini file
===================================

allow_call_time_pass_reference = on
allow_url_fopen = on
expose_php = off
max_input_time = 160
variables_order = "EGPCS"
upload_tmp_dir = /tmp
precision = 14
url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=,fieldset="
session.save_path = "/tmp"
file_uploads = On
register_globals = off
upload_max_filesize = 700M
post_max_size = 1000M
max_execution_time = 300
memory_limit = 32M

this is my .htaccess file
===================================

### SILVERSTRIPE START ###
RewriteEngine On

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* /sapphire/main.php5?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###

And I added this to sapphire/main.php
===================================

// I uncommented this line
ini_set("memory_limit","32M");

// I added this to redirect all requests for peterprins.biz to www.peterprins.biz to improve google ranking
if(!stristr($_SERVER["HTTP_HOST"], 'www')){
   header("HTTP/1.1 301 Moved Permanently");
   header("Location: http://www.peterprins.biz" . $_SERVER["REQUEST_URI"]);
}

Avatar
ipure

Community Member, 1 Post

10 December 2007 at 3:34pm

I'm having the same problem! it is really frustrating... I had the site all set up, and it worked fine when I was logged in.. but as soon as i logged out to test on another browser I got the errors.. I uninstalled and re-installed.. and still nothing.. I've tried just about every .htacces setup and nothing. I was really impressed with this cms... and really pissed its not working.

when you ran the install did it say that it could not tell if your .htaccess and folders where not writable? I had that problem, and the server memory, but it still let me install... maybe Godaddy just sucks...

it would be awesome if we could get some help on this issue...

o I have also noticed that the gallery does not work with safari... it will not activate lightwindow..

Avatar
vcmusic42

Community Member, 22 Posts

13 December 2007 at 10:39am

Pete - are you viewing your site in Firefox, or IE? Just curious, because I've also got shared hosting on GoDaddy and am getting the same error, but only in FF.

I also checked out your site in IE, and pressed reload on several pages, and didn't get an error.

I'm not a developer, but the similarities in our cases makes me think it's got something to do with their shared hosting and the maximum number of allowable connections (either with MySQL or the server). I know for their economy hosting it's 50, and for deluxe, it's 100. I would think about upgrading to see if it helps the issue, but I'm wary. I've never had issues with them before, and SS seems more lightweight than other CMSs I've tried...and my page is simple... so what gives?

It's almost as if FF is communicating with SS in such a way that more connections or data gets transmitted...so the server can't handle it. But with more people using FF nowadays, we can't just dismiss this.

We all have shared hosting and possible issues with mod_rewrite - and we went ahead and installed despite some warnings. I'm not a specialist with .htaccess. Any code gurus have any ideas about how we can make sure our setups are LEGIT so we can run Silverstripe smoothly?

Personally I know I will be sending all my clients to SS once I get it figured out, so any help is appreciated!

Avatar
vcmusic42

Community Member, 22 Posts

13 December 2007 at 5:44pm

Ok, I talked to GoDaddy's tech support and they said they couldn't give me error logs so I could track down exactly what was causing the 500 error. I told them I knew of several other people in the same boat - using their shared hosting, getting errors, etc. Once again, the tech tested my site in IE, with no errors...it was only happening in FF.

Conclusion: Their reps are nice over the phone, but GoDaddy sucks.

Going with my hunch about Php memory and max connections, I ambled over to [url=http://www.medialayer.com/]Medialayer[/url] - I helped a client get set up with them earlier this year and knew that they'd be a little less stingy with their resources, since they specialize in application hosting and boast great uptimes and support. I was right. Without changing anything in the .htaccess, my Php Memory was set to 64MB.

I switched my hosting, installed SS again, and haven't had any errors since.

I think GoDaddy works well for some things, but for SS, not so much. best of luck!!

Avatar
Peter Prins

Community Member, 8 Posts

14 December 2007 at 11:28am

Hey vc - I've got the deluxe hosting and i've only looked at my ss site in firefox up to this point. But now I just took a look at it in Safari 1.3.2 and I get the same Internal Server Errors when I click a link to the same page I'm already viewing for example I'm on the home page and I click (you have to click not just refresh) Home and it brings up the 500 Internal Server Error. I could be wrong but I think it's a php memory problem not a browser issue.

Here's a godaddy help page showing them setting the memory_limit = 50M
http://help.godaddy.com/article.php?article_id=1475&topic_id=58

From this it stands to reason that we can change the memory_limit but I think they have disabled that on our hosting accounts for php 5 or simply overlooked setting it up so that we can change it for php 5 (i bet it works for php 4 but ss won't run under php 4) which is probably why we get the 500 internal server errors

Avatar
sonictruth

Community Member, 3 Posts

1 February 2008 at 3:52am

If you have the "INTERNAL SERVER ERROR" problem when you refresh and you're using firefox with SilverStripe at godaddy
comment the line:
//header("Last-Modified: " . self::gmt_date(self::$modification_date));
in sapphire/core/HTTP.php

When this line is enabled the next request from firefox will be with If-Modified-Since header.
This seems to mess up godaddy... don't know why yet.

Avatar
coupleofcents.com

12 Posts

7 February 2008 at 12:53pm

Here is a full write up for installing SS on Godaddy:

http://www.coupleofcents.com/installing-silverstripe-cms-on-godaddy

My installs seem to work perfectly on GoDaddy.

Avatar
coupleofcents.com

12 Posts

27 March 2008 at 12:03am

Sorry about the above link. I decided to close that site due to other commitments. However, because I am now getting hundreds of 404's for that url each week, I have reposted the tutorial here:

http://old.coupleofcents.com/installing-silverstripe-cms-on-godaddy