Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

new hosting provider, new challenge


Go to End
Reply


14 Posts   2934 Views

Avatar
mbellino

Community Member, 32 Posts

13 December 2007 at 1:00am

Edited: 13/12/2007 1:02am

Hello everybody

After a few installation and configuration issues on the part of the hosting provider (metanet.ch), I have a running website with SS 2.2.0.
The last issue I have is the sitemap.xml with the error:

Fatal error: Call to a member function getSession() on a non-object in /home/httpd/vhosts/saner-mindt.ch/httpdocs/sapphire/core/Session.php on line 32

Because I'm not sure whether the problem is again on the hosting providers part, I have tried to create an identical copy on another hosting provider (hoststar.ch) for testing purposes.
There I had a working site with SS 2.1.1.

Here is the procedure I followed:
1) cleaned the folder structure
2) erased the database
3) copied the full folder-structure from the other hosting provider and adapted the access rights.
4) changed the configuration file (user, db, password).
5) imported the database dump into the db

When I tried to access the "replicated" website (http://smc-cms.bellino.ch/) I got the message:

Parse error: parse error, unexpected T_ARRAY, expecting '&' or T_VARIABLE in /home/www/web294/html/web-home-mbe/smc-cms/sapphire/security/Authenticator.php on line 38

Does anyone has an idea?

Cheerio

Mario

Avatar
fordy

Community Member, 46 Posts

13 December 2007 at 1:56am

I have just checked my server logs on a prob i am having, and i am getting the same error. Have you managed to sort it yet? I am pretty stumped on this one.

Avatar
mbellino

Community Member, 32 Posts

13 December 2007 at 2:20am

Hello Fordy

Which problem do you mean?
The first one with the sitemap or the issue with the authenticator?
Unfortunately I have no access the the error logfiles at the hosting provider.

Avatar
fordy

Community Member, 46 Posts

13 December 2007 at 3:03am

Hi mbellino,

I am having a problem with the second error, the authenticator. It is the same as yours (unexpected T_ARRAY....)

It works fine locally but when i uploaded to GoDaddy, it went pear shaped :-(

Are you still having the prob or have you sorted it?

Regards

Fordy

Avatar
mbellino

Community Member, 32 Posts

13 December 2007 at 3:27am

The problem is still existent :-(
I'm also waiting for an answer or a hint.

Avatar
Andy

230 Posts

13 December 2007 at 10:22am

The parse error is most probably due to running on PHP4 rather than PHP5.

Avatar
mbellino

Community Member, 32 Posts

13 December 2007 at 11:40am

Hello Andy

Thanks for feedback. PHP5.0.5 is running.

Have a look at: http://smc-cms.bellino.ch/test.php

Cheerio

Mario

Avatar
vcmusic42

Community Member, 22 Posts

13 December 2007 at 5:37pm

I had a similar error - not the exact one you're experiencing - and it was a matter of deleting an extra "}" in the code. You've been wrestling with this for a while, though, so I'm sure you've already looked at the code a million times!

Go to Top