Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Can't upload images


Reply

66 Posts   394993 Views

Avatar
SLJ

9 February 2008 at 7:36am Community Member, 23 Posts

I had this problem today as well. I just replaced both the swfupload.js and the swfupload.swf files with the ones from the newest SWFUpload v2.0.2.Release.zip file at http://www.swfupload.org/node/1/release . I used the swfupload_f9.swf file from the archive. My uploads are working now. I'm still testing and I'll post again if I have problems but so far so good.

Hope this helps.

SLJ

Avatar
Digital-Punk.co.uk

9 February 2008 at 10:52pm (Last edited: 9 February 2008 10:53pm), Community Member, 51 Posts

to SLJ: anf for you also is working image upload on the right panel?

Avatar
primoz

13 February 2008 at 6:35am Community Member, 1 Post

hello!

insert into .htaccess

<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

and woila, difference is obviously. But still no-go.

my apache loaded modules:
mod_suphp, mod_security, mod_php5, mod_ssl, mod_perl, mod_frontpage, mod_setenvif, mod_so, mod_headers, mod_expires, mod_auth_anon, mod_auth, mod_access, mod_rewrite, mod_alias, mod_userdir, mod_actions, mod_imap, mod_asis, mod_cgi, mod_dir, mod_autoindex, mod_include, mod_info, mod_status, mod_negotiation, mod_mime, mod_log_referer, mod_log_agent, mod_log_config, mod_env, mod_vhost_alias, http_core

one of those modules is stopping my upload...

agree?

Avatar
lukeasrodgers

15 February 2008 at 7:38am Community Member, 2 Posts

I have the exact same problem.
I can't view see any images to insert, other than the default silverstripe logo. It all works properly in IE6 but not in Firefox (probably first and last time I'll ever say that), and appending /?flush=1 does nothing. Site is hosted on site5.

Avatar
paddimac

12 March 2008 at 10:18am Community Member, 4 Posts

Nice one. This worked for me:

Hello everybody

I've donwloaded the newest version of SWFUpload (Version 2) from http://www.swfupload.org/node/1/release and replaced the file
jsparty/SWFUpload/SWFUpload.swf
with this one
swfupload/FlashDevelop/Flash9/swfupload_f9.swf
from the archive

And now, it works on my server.

It would be nice if somebody could try this on his website and post here, if this works for him, too.

PS: Don't forget to clear the cache...

phinel

Avatar
qwfp

14 March 2008 at 5:45pm (Last edited: 14 March 2008 6:24pm), Community Member, 1 Post

Still experiencing the same problem, even with the latest 2.2.2rc2 release. I personally would like to have an alternative to SWFUpload (just a plain upload form), because it's causing so many people so many problems. Please fix this before 2.2.2 .

Update: SWFUpload v2.1.0 Beta works in the Files & Images section, but doesn't work and redirects to the home page from the sidebar (losing all changes). In the meanwhile I've commented out the relevant 11 lines in HtmlEditorField.php starting with « new LiteralField('AddFolderOrUpload', ».

Avatar
Howard

19 April 2008 at 12:14am (Last edited: 19 April 2008 12:15am), Community Member, 215 Posts

Hi there, I have been having the same issue (clicking the upload buttons but nothing happens) and so I updated the swfuploader as instructed by earlier posts in this thread and now uploading in the "Files and Images" tab works perfectly in both ff(mac) and ie but clicking on upload in the sidebar links to the main page of the website with a '#' on the end of the address e.g. http://www.testsite.com/#

This is looking like a bug that needs to be addressed.

SS 2.2.1

Avatar
Lifepod

30 April 2008 at 11:16pm Community Member, 4 Posts

Hi folks. Wow... what a lot of work. As requested on this forum string, I uploaded the latest version of swfupload file and it solved my issue with uploading images and now I am able to view them in the side panel - all in Firefox. What a relief.

:-))