Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Can't upload images


Reply

66 Posts   394988 Views

Avatar
mundgold

22 December 2007 at 3:19am Community Member, 19 Posts

It's the same to me...

I can only upload the images with ie. Not with firefox 2.0.0.11 on windows xp - but on firefox 2.0.0.11 on windows vista it works ...

Strange

Avatar
dio5

22 December 2007 at 3:22am Community Member, 501 Posts

That is very strange indeed.

But it doesn't make sense to me why it worked on my previous then.

Avatar
alfa

22 December 2007 at 3:32am Community Member, 20 Posts

I dont have any explanation for it either, i had the same issue using FF on WinXP and after a few days it was solved by it's self...cant find an logic explanation...

I'm changing hosting company and i have some problems, when i make a new installation i'll tell you if problem persists...

Cheers,

Avatar
mbellino

22 December 2007 at 3:39am (Last edited: 22 December 2007 7:40am), Community Member, 32 Posts

@dio

I've talked to my other hosting provider (have two different).
Both have confirmed that their mod security module blocks some upload requests.

The provider sent me the logfile below:

Request: www.hostname.tld 194.30.181.170 - - [21/Dec/2007:15:30:38 +0100] "POST /admin/assets/assets/index/root?executeForm=UploadForm&SecurityID=1000842174&PHPSESSID=1cacca4505e897ab10c930891b66b84f HTTP/1.1" 403 316 "-" "Shockwave Flash" - "-"
----------------------------------------
POST /admin/assets/assets/index/root?executeForm=UploadForm&SecurityID=1000842174&PHPSESSID=1cacca4505e897ab10c930891b66b84f HTTP/1.1
Accept: text/*
Connection: Keep-Alive
Content-Length: 183438
Content-Type: multipart/form-data; boundary=----------gL6KM7ei4Ij5Ij5GI3Ef1KM7Ef1KM7
Host: www.hostname.tld
Pragma: no-cache
User-Agent: Shockwave Flash
X-BlueCoat-Via: 4B79DA5FA334B31F
mod_security-message: Access denied with code 403. Error processing request body: Multipart: final boundary missing [severity "EMERGENCY"]
mod_security-action: 403

[Fri Dec 21 15:29:58 2007] [error] [client 194.30.181.170] mod_security: Access denied with code 403. Error processing request body: Multipart: final boundary missing [severity "EMERGENCY"] [hostname "www.hostname.tld"] [uri "/admin/assets/assets/index/root?executeForm=UploadForm&SecurityID=1000842174&PHPSESSID=e0857eeac5e121ddfeddb4183ae09dbf"]

Cheerio

Mario

Avatar
dio5

22 December 2007 at 7:44am Community Member, 501 Posts

Thanks mbellino.

I'll check if I can find something alike.

It's still weird that IE does work.

Avatar
phinel

22 December 2007 at 10:34am Community Member, 16 Posts

Hello

I've contacted my provider with this problem. They wrote me, that this is a bug in Adobe Flash Player which is bloicked by the apache-module mod_security. They told me that this module is like a firewall and could not be disabled because of security reasons.

I hope this helps.

phinel

Avatar
marikas

23 December 2007 at 10:16pm Community Member, 24 Posts

I had this same problem after I installed 2.2.1rc2. However, just before I posted a bug report, I re-installed it again and everything worked fine. The only difference between the two installs was that the former was installed over an existing SS db, while for the second I created a new db and did a clean install. Whether or not installing over an existing SS database was actually the cause of the problem, I can't say, but after a clean install, everything worked fine.

Avatar
Stempy

28 December 2007 at 1:08pm 2 Posts

Similar problem on my live server.

When in the content editor, I go to upload image (via sidebar on right) and it refreshes but appears not to have done anything, yet the files have uploaded, (viewable from ftp client) and Files & Images show them.

Just on the sidebar it doesnt list the images uploaded.