Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

installation problem

Go to End

4 Posts   2339 Views


Community Member, 8 Posts

20 December 2007 at 9:37pm

ive uploaded the files to a ftp server and tried to install but got the following failure:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: NO) in /data/home/m1204/rr-r/htdocs/sapphire/core/model/MySQLDatabase.php on line 39

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /data/home/m1204/rr-r/htdocs/sapphire/core/model/MySQLDatabase.php on line 40

Fatal error: DATABASE ERROR: Couldn't connect to MySQL database in /data/home/m1204/rr-r/htdocs/sapphire/core/model/Database.php on line 397

the file are not modified after installation on local machine ...

so can anyone help me with this?



Community Member, 787 Posts

21 December 2007 at 1:15am

Seems your database settings are wrong.

Check the path and credentials for the mysql database. Looks like you just uploaded your local-config (root with no password).


Community Member, 8 Posts

21 December 2007 at 3:57am

thats it. i just uploaded the files.

but what shall i change?

i just started with ss a few days ago over google code so im still noob...


Community Member, 25 Posts

21 December 2007 at 7:01am

Try downloading the PHP based installer (silverstripe-v2.2.0.tar.gz) and upload it to the webserver (do not install on local machine first) and then it will ask you for your mysql settings.

You could probably change the mysite/_config.php to the correct setting too, but then you have to copy the database manually to your server too.