Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Translatable Fatal error


Reply

18 Posts   8791 Views

Avatar
Nimolix

23 February 2008 at 8:47am Community Member, 1 Post

I've encountered the same problem; I want to make some custom fields translatable.
I'm working on a web project using SS and today when I wanted to implement custome field functionality, It gave me 'can not run query' error and referred to non existing column in SiteTree table named OriginalLangID.
As I should deliver my project next week, I would appreciate to access the patch early. I was thinking about extending $db static variable in SiteTree class and add all of custom fields and then selectively disable them in each page type I've created. Although it is non-efficient but quick fix that I think functional.
I've not tried daily builds yet, Do u think if I upgrade my local copy with latest daily build files, my problem is solved?

Avatar
Craneway

23 February 2008 at 10:51am 20 Posts

I tried to do the same but was not lucky. My site has just several pages with the same sidebar content in custom areas. So, I did a trick creating separate pages with the needed content for custom blocks and called that content from those blocks in the template.
This is not a perfect solution, but I'll wait until the patch is released and custom fields that we create for the cms become fully translatable.

Avatar
Fuzz10

12 March 2008 at 2:47am Community Member, 787 Posts

Is there any news on the translations of custom fields ?
Anyone had any succes with the i8n functionality in a production environment ?

Avatar
Ingo

12 March 2008 at 9:27am Forum Moderator, 801 Posts

no news yet, make sure to follow the progress of these tickets:
http://open.silverstripe.com/ticket/2202
http://open.silverstripe.com/ticket/2165

Avatar
Fuzz10

12 March 2008 at 9:42pm Community Member, 787 Posts

Thanks Ingo...

Just to be sure ; there is no (quick,dirty) way to use the I8N functionality for pages that have custom fields , correct ?

Avatar
Ingo

12 March 2008 at 9:54pm Forum Moderator, 801 Posts

not that i'm aware of, sorry mate

Avatar
pIscIs

10 June 2008 at 1:32am Community Member, 8 Posts

so is where any avalaible branch with this bug fixed?

Avatar
YellowDuck

8 July 2008 at 7:05pm Community Member, 4 Posts

Any update on this? I've stumbled across the exact same problem and I'm in desperate need to get a fix for this...

I'm running SilverStripe 2.2.2 and the problem is still the same.