Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Plain theme


Reply


5 Posts   1378 Views

Avatar
Wojtek

Community Member, 149 Posts

18 January 2008 at 1:40pm

Edited: 18/01/2008 1:40pm

hey!
I have just developed a new theme, which is called "plain". It is a business green-on-white theme that you should definitely have a look at!

to download, click: [url=http://silverstripe.pl/plain.tar.gz](download)[/url]

Feedback appreciated

Avatar
Willr

Forum Moderator, 5513 Posts

18 January 2008 at 3:49pm

Edited: 18/01/2008 3:50pm

Wojtek! Feedback

- A couple typography points, use "Trebuchet MS",Arial,Verdana instead of Arial
first (its in the * rule I think. I quite like it with Trebuchet and also for the
paragraphs. And for typography line 6 - p, ul, td.. Instead of 12 try 11px. I know
picky but it just seems nicer to me and thats what the original theme had and it was nice

- Currently online area in the forum page is pretty spaced out. I mean majorly too
much room and padding. Tighten that up

- the menu 2 doesnt quite match the template. Should be blue and without the
underline. You also need the .current link styling for it

- comments are again too spaced out. Have a play with the layout of that

- you need a typography.css file in the plain/css/ folder. Otherwise it actually breaks
:P Not only do you want it to make the theme look pretty over both the cms and front
end if you do not have on you get what happens on plain on the demo site. Including
the cms's default one with the overflow hidden stuff!!!

Even if its blank its better then none, but would be good to add the p, a, ul, ol,
etc into it.

Avatar
Jeff

Community Member, 32 Posts

18 January 2008 at 8:31pm

I'm not sure if it's because of the default forum style override, there seems to be some layout problems with the forum module. eg.) http://demo.silverstripe.com/general-discussion/flat/1?theme=plain&flush=1

Avatar
Wojtek

Community Member, 149 Posts

18 January 2008 at 9:26pm

Will:
as for the typography, I have mentioned it that I forgot to create a typography file and I couldn't fix it before you accept the theme to silverstripe.com/themes

@jeff - it's about the demo bug

I'll fix it in a few minuts/hours and post it :)

Avatar
Wojtek

Community Member, 149 Posts

19 January 2008 at 1:13am

I have corrected all the issues reported by Will =]