Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Homepage almost finished - then SQL error


Reply


4 Posts   1904 Views

Avatar
dille4

Community Member, 14 Posts

29 January 2008 at 1:53am

Edited: 29/01/2008 1:55am

Hi guys,

I hope someone can help me. I was almost finished with my homepage and after inserting pictures to a page I got a database error. (See attachment)

At that point in time I didn't change anything on the php code at all. I was rather working on the style of my homepage. (Writing text and inserting pictures). [All pictures have been properly saved in different folders in the "Pictures and Files' management page]

Is there anything I can do to get my work back? Otherwise one week of work will be gone ...

Cheers,
Tom

Avatar
Fuzz10

Community Member, 787 Posts

29 January 2008 at 9:44am

Are you using the latest SS version?

I experienced some very weird behaviour with PHP 5.1.2 and older Silverstripe versions.

Avatar
dille4

Community Member, 14 Posts

29 January 2008 at 11:23am

Hi Fuzz,

I'm using the SS 2.2.1 in the mode "Empty template" on PHP v 5.2.1 and MySQL.

PS: If I want to login normally through www.myhomepage.com/admin I get following error message:

Avatar
LarcenIII

Community Member, 8 Posts

18 February 2008 at 7:36pm

That's a connection issue. Can you access the database through your host?