Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Russian Unicode problem. What to do?


Go to End
Reply


26 Posts   73429 Views

Avatar
Craneway

20 Posts

30 January 2008 at 12:40pm

Edited: 30/01/2008 12:47pm

Hi, I am making a bilingual site in English as default and Russian as translation.
Everithing works fine, but in the Russion translation output (in CMS and both in draft and live) there are some characters substituted by an "unrecognized" symbol.

Actually, there are two of them:

%u0448

(stands for "ш") and

%u0418

(stands for "И").

Any suggestions?

Avatar
Ingo

Forum Moderator, 801 Posts

31 January 2008 at 12:14am

can you make sure that your browser is set to handle utf8 (e.g. "page information" popup in firefox)? which browser are you using? can you check if using another font solves the issue?
can you have a look if the strings are correctly saved via phpmyadmin? (make sure its set to utf8 output as well)

Avatar
Craneway

20 Posts

31 January 2008 at 5:27am

Edited: 31/01/2008 5:50am

Hi, Ingo!
I checked what you said. Changing the font doesn't help, The same problem with the characters in Firefox 2.0.0.11, Opera 9.25, IE7. Firefox Page Info says the encoding is utf-8.
The strings in db are not saved correctly. When I open a Content field in SiteTree_lang table via phpmyadmin I see only "Впервые! Только у нас! Вы с".
Phpmyadmin is set to utf-8. It says that the rows collation is utf8_general_ci.
But when I open a ss database to view the tables the collation is indicated as cp1251_general_ci.

Russian characters problem appears regardless of whether it is a translation or default language.

The site runs on a Russian server, where utf-8 wordpress (one language - Russian) works fine with the same parameters.

Just started to translate the content. It looks like I can't use SS for Russian content sites at all!

Avatar
Craneway

20 Posts

31 January 2008 at 7:35am

Tested the default installation on another server with BlackCandy theme. The same problem with Russian characters! Just impossible to create a site in Russian.

Avatar
Ingo

Forum Moderator, 801 Posts

31 January 2008 at 8:55am

> Everithing works fine, but in the Russion translation output (in CMS and both in draft and live) there are some characters substituted by an "unrecognized" symbol. Actually, there are two of them

so you're just having problems with two characters of the kyrillic alphabet, and the others work fine?

> But when I open a ss database to view the tables the collation is indicated as cp1251_general_ci.

the tables itself are in your default collation, but all fields that can store language content (varchar/text) fields are marked as "utf8_general_ci" - can you check this is the case on your db?

Avatar
Craneway

20 Posts

31 January 2008 at 10:14am

>the tables itself are in your default collation, but all fields that can store language content (varchar/text) fields are marked as "utf8_general_ci" - can you check this is the case on your db?

I checked it. All the mentioned fields are marked as "utf8_general_ci". I can't believe it doesn't work! There are only 2 characters unrecognized.

Is it possible, that a problem could be with WYSIWYG editor?

Avatar
Craneway

20 Posts

31 January 2008 at 10:39am

I am not sure the problem is with i18n.

On another default istallation I disabled it. But the problem remains.

Avatar
Craneway

20 Posts

31 January 2008 at 9:29pm

Edited: 31/01/2008 9:31pm

Hello again! I attach a screenshot of how the cyrillics look like on the site.
Is there anyone who managed to produce Russian cyrillic output on SilverStripe?
I really need to know if it's only my problem, or there is a bug in SS.

It sounds weird, 2 characters are missing. I have never seen anything like that before.

Go to Top