Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

SilverStripe 2.0.1


Go to End
Reply


10 Posts   6340 Views

Avatar
Andy

230 Posts

26 March 2007 at 5:47pm

Edited: 26/03/2007 5:47pm

Hey,

SilverStripe 2.0.1 is nearly ready to be released, so we thought we would post it on the forums for some public testing before officially releasing it.

You can find it here: http://www.silverstripe.com/assets/temp/silverstripe-v2.0.1-rc2.tar.gz

It contains the following fixes:
- Text->FirstParagraph() now only shows the first paragraph
- Fixed HTMLText->Summary()
- Fixed layout issues on IE7 for TreeDropdownField
- Don't show Akismet errors to user
- Removed overloaded MemberTableField->sourceItems() that was causing problems
- Improved layout of UserDefinedForm submissions in CMS
- Fixed UserDefinedForm submission emails
- Fixed UserDefinedForm permissions
- If a file extension doesn't have a maximum upload size associated with it, then allow uploads of any size
- Fixed a bug with the TreeMultiselectField that prevented it from displaying the checkboxes
- singleton() now uses Object::create
- Made Scheduled tasks concrete so they can be instantiated
- Fixed sizing of tabs in CMS
- Fixed popup for single asset in Files & Images section
- Mime types fallback for servers don't have /etc/mime.types
- Fixed link to CMS on default homepage
- TableField fixes
- Installer fixes
- Fixed MySQL version check
- Merge with existing .htaccess file
- Test that mod_rewrite is working
- Added option to delete installer files after successful install

Please post any bugs, especially ones relating to the installer, in this thread.

Happy testing!

Avatar
laktek

Google Summer of Code Hacker, 76 Posts

27 March 2007 at 6:02pm

I tried to install SilverStripe 2.0.1 on my apache2 server with mod_rewrite enabled, but rewritetest doesn't seem to validate why is that ?

Avatar
ckim

Community Member, 18 Posts

27 March 2007 at 6:29pm

Edited: 27/03/2007 6:34pm

Contact form - still can't add fields http://www.silverstripe.com/bugs/flat/622

Virtual page does not work. You can't click to enumerate links

Redirector to another page does not work. Same as virtual page.

Image and file upload does not work and file sizes are not provided.

Can we do this over mailing list or bug track?

Avatar
Tim

Core Development Team, 201 Posts

27 March 2007 at 7:36pm

Edited: 27/03/2007 7:40pm

Hi Ckim

Re bug tracking, we'll be bringing Trac on-line shortly which will make managing bugs a lot easier.

Avatar
Andy

230 Posts

27 March 2007 at 7:47pm

laktek, the most likely reason is although mod_rewrite is enabled it isnt configured properly for the directory you installed silverstripe in. Check that AllowOverride is set for that directory. This was a common problem with earlier releases, which is why we've introduced the test.

If you are sure that it is configured properly, you can rename .htaccess_rewrite to .htaccess . If this solves the problem, then the rewrite test doesn't work properly and I need to look into it..

Avatar
laktek

Google Summer of Code Hacker, 76 Posts

27 March 2007 at 10:29pm

It seems AllowOverride is the issue, it works fine when I copy SilverStripe directly into /var/www/, without having virtual directories.

Avatar
qhoxie

Google Summer of Code Hacker, 39 Posts

28 March 2007 at 11:21am

@laktek, did the vhost config have the same AllowOverride setting as the default zone?

Avatar
Sigurd

Forum Moderator, 628 Posts

28 March 2007 at 11:26am

Can people please check the wording of the mod_rewrite error? For instance, I have confirmed one particular PHP4 host (which won't work), SilverStripe 201rc2 complains "Apache/1.3.37 Server at XYZ Port 80. Without Apache I can't tell if mod_rewrite is enabled."... hence we need to fix up the check, rather than the server ;)

Go to Top