Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Insatllation: "getting past go"


Reply


5 Posts   9002 Views

Avatar
Bruce

Community Member, 29 Posts

12 February 2008 at 5:56pm

Hi,
... & help.
I'm trying to install onto a Linux box.
Red Hat   Linux 2.6.20-1.2320.fc5
(MySQL 5.0.27)
(PHP version 5.1.6)
When I run up the Silverstripe install page, it says "happy campers" *except for:
1. (in red) GD2 support
and
2. "Check that the php.ini setting allow_call_time_pass_reference is on"

Now the second one I'm picking is a warning only,

... but the cryptic "GD2 support"
tends to suggest I need some "GD2"
... so I went & got gd-2.0.35 from www.libgd.org
and did all the configure/make install routine, only to discover, that the
php configure parameter --with-gd" needs to be added to the configure line.
So do I have to now also manually configure php ,make & install to get this going ...
I'm a bit reluctant to dive in here unless needed.

Avatar
SirSpammenot

Community Member, 9 Posts

14 February 2008 at 11:37am

I think you are correct. You are going to recompile php no matter what you do.

My suggestion is to update to newer php if possible. I was using 5.12 and found object handling problems only marked fixed in 5.2.0 version. Minimum php version for SS is actually 5.2 according to download page.

My old (v10.2) openSuSE box is now 5.2.5 and runs OK.

Is this your test box, a production box, or a hosted server?

Avatar
Bruce

Community Member, 29 Posts

17 February 2008 at 6:00pm

Okay, I decided to bite the bullet and upgrade php.
seeing as I would need to re-build it anyway, so I got php 5.2.5 and then ...

I took the current php configure settings (from phpinfo() ) and used them for 'configure'.
I'll spare you the sordid details, but after installing pcre, pspell etc, I got a clean 'configure' run.
'make' seemed to be happy too, but when I got to "make test" things went horribly wrong.

[root@fedora php-5.2.5]# make test

Build complete.
Don't forget to run 'make test'. (sic)

PHP Warning: PHP Startup: ldap: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=0
PHP compiled with module API=20060613, debug=0, thread-safety=0
These options need to match
in Unknown on line 0
PHP Warning: PHP Startup: mysql: Unable to initialize module
Module compiled with module API=20050922, debug=0, thread-safety=0
PHP compiled with module API=20060613, debug=0, thread-safety=0
These options need to match
in Unknown on line 0
... etc

I had removed a parameter '--with-apxs2=/usr/sbin/apxs' which was proving problematic as the files didn't seem to be available, but I don't think that is related.
This seems to be indicating a need to now re-build all the other applications!
This is my development box, & I don't what to blow away the system by doing something foolish.
Can anyone advise where I have gone wrong?

Avatar
SirSpammenot

Community Member, 9 Posts

20 February 2008 at 10:12am

This is why I stopped fearing and learned to love package management (Its the bomb).

The libraries that php is calling for LDAP and mySQL access are old... and they didn't get updated when you updated php. So now your php-lib-mysql versions are out of sync. Fear not you are very close...

From: http://www.php.net/mysql
Requirements
In order to have these functions available, you must compile PHP with MySQL support.
Installation
For compiling, simply use the --with-mysql[=DIR] configuration option where the optional [DIR] points to the MySQL installation directory.

So just another compile, add in mysql and LDAP switches (with the correct paths to the mySQL/LDAP sources). Note you may need the sources for the client(s) too - cannot remember. There are more detailed instructions on the php site too.

email me directly if you want to - I can't check the forum every day like I want. :)

Avatar
Bruce

Community Member, 29 Posts

1 March 2008 at 2:27pm

Edited: 01/03/2008 3:04pm

Ummm...
yeah, so

yum install php-gd


then re-start httpd
did the job.
Kind of embarrassingly simple.
Installing SilverStripe...
Installed SilverStripe successfully.
... now the fun begins!