Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Problem with the Flickr Gallery module


Reply

2 Posts   1961 Views

Avatar
GangsterPanda

17 February 2008 at 1:08am Community Member, 5 Posts

Hello!

I'm having some issues with my Flickr Gallery module on a rather fresh install of Silverstripe.
After removing '--without-curl' '--without-curlwrappers' and '--disable-simplexml' I managed to get most of the error message out of the way, and now I'm stuck with one I find it hard to get any decent info out of.

"ERROR:
Error

The website server has not been able to respond to your request."

This is the output from PHPinfo's "Configure command": './configure' '--prefix=/usr/lib/php5' '--host=i686-pc-linux-gnu' '--mandir=/usr/lib/php5/man' '--infodir=/usr/lib/php5/info' '--sysconfdir=/etc' '--cache-file=./config.cache' '--disable-cli' '--with-apxs2=/usr/sbin/apxs2' '--with-config-file-path=/etc/php/apache2-php5' '--with-config-file-scan-dir=/etc/php/apache2-php5/ext-active' '--without-pear' '--disable-bcmath' '--without-bz2' '--disable-calendar' '--with-curl' '--with-curlwrappers' '--disable-dbase' '--disable-exif' '--without-fbsql' '--without-fdftk' '--disable-filter' '--disable-ftp' '--without-gettext' '--without-gmp' '--disable-hash' '--without-iconv' '--disable-ipv6' '--disable-json' '--without-kerberos' '--enable-mbstring' '--with-mcrypt' '--without-mhash' '--without-msql' '--without-mssql' '--with-ncurses' '--with-openssl' '--with-openssl-dir=/usr' '--disable-pcntl' '--disable-pdo' '--without-pgsql' '--disable-posix' '--without-pspell' '--without-recode' '--disable-shmop' '--without-snmp' '--disable-soap' '--enable-sockets' '--without-sybase' '--without-sybase-ct' '--disable-sysvmsg' '--disable-sysvsem' '--disable-sysvshm' '--without-tidy' '--disable-tokenizer' '--disable-wddx' '--disable-xmlreader' '--disable-xmlwriter' '--without-xmlrpc' '--without-xsl' '--disable-zip' '--with-zlib' '--disable-debug' '--enable-dba' '--without-cdb' '--with-db4' '--without-flatfile' '--without-gdbm' '--without-inifile' '--without-qdbm' '--without-freetype-dir' '--without-t1lib' '--disable-gd-jis-conv' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--without-xpm-dir' '--with-gd' '--with-mysql=/usr' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--without-mysqli' '--with-readline' '--without-libedit' '--without-mm' '--without-sqlite'

Anyone knows what might be causing this error? The Gallery is a FlickrGallery page type, and is put directly below the "Site Content" in the site tree. It's also set to display any photos tagged with a certain word, 20 pr. page and sort by most interesting.

Avatar
GangsterPanda

17 February 2008 at 1:25am (Last edited: 17 February 2008 1:26am), Community Member, 5 Posts

I fixed this, it seems I removed "FlickrService::setAPIKey('Your-API-KEY');" from _config.php when I was trying to resolve the errors that preceded the last one and I had forgotten it. Added it back, and everything seems to be working just fine now :-)