Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

problem installing silverstripe on a plesk server


Reply

6 Posts   13858 Views

Avatar
blaater

25 February 2008 at 6:15am (Last edited: 25 February 2008 6:16am), Community Member, 22 Posts

Hello,

I've just got a new server with plesk 8.3 installation on centos, but having trouble with installing silverstripe. When I run the install.php everything looks allright exept for my php.ini. There's a warning that says:

allow_call_time_pass_reference is set to '' in php.ini. You can install with allow_call_time_pass_reference not set, but some warnings may get displayed. For best results, turn it on.

When I click install the installer stops at: "Building database schema..." and is immediatly finished loading. There are no errors on my screen. When I look in the errorlog of the domain i see a couple of errors, the first one is:

PHP Warning: is_dir() [<a href='function.is-dir'>function.is-dir</a>]: open_basedir restriction in effect. File(/var/www/vhosts/mydomain/httpdocs/../) is not within the allowed path(s): (/var/www/vhosts/mydomain/httpdocs:/tmp) in /var/www/vhosts/mydomain/httpdocs/sapphire/core/ManifestBuilder.php on line 93, referer: http://www.mydomain/install.php

Does anybody know what causes this problem?

Thanks in advance!

Avatar
Wojtek

25 February 2008 at 7:48am Community Member, 149 Posts

I'm using plesk and it works nice to me.

The problem is not in plesk itself, maybe you just haven't set a high enough memory limit? (check the forums for this)

Avatar
banal

25 February 2008 at 8:01pm (Last edited: 25 February 2008 8:08pm), Community Member, 901 Posts

That's most likely because PHP Safe-Mode is enabled ([url]http://ch2.php.net/features.safe-mode[/url]). You should be able to disable safe-mode in your Plesk Control Panel.

Edit
Since your Error comes from a open_basedir restriction (possibly locking you out of the tmp directory where the ManifestBuilder wants to write to). It should be sufficient to disable open_basedir, or (more secure) set it to the required directories (separated with a colon).

Avatar
paddimac

12 March 2008 at 4:54am Community Member, 4 Posts

I am having the same problem. I have plesk 8.3. I have checked the memory settings and there is plenty of memory. Has anyone been able to solve this problem?

Avatar
OzziNL

17 June 2008 at 8:46pm Community Member, 37 Posts

Still no solution for this problem? Also struggling with this here.

Avatar
codepotato

10 October 2008 at 3:54am Community Member, 14 Posts

Are you still having issues with this? Let me know if you do, as i use a plesk server, and have installed this many times without any issues.