Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Using iFrames


Reply

6 Posts   2527 Views

Avatar
ryal001

9 March 2008 at 1:06pm Community Member, 1 Post

Hi,

I want to insert a Google map into an ordinary page using the Google iFrame code generated on Google/Maps. I am aware of the Maps module but it seems very complicated just to show a static map (i.e. I can't figure out how to use it).

Anyway, the SilverStripe admin page editor (HTML view) seems to automatically delete the <iframe> tags and all I have left is a hyper link to the Google map page.

Is there any way around this?

Thanks,

Rob

Avatar
tschunde

9 March 2008 at 2:48pm Community Member, 3 Posts

This would also be interesting to know for me too.

Avatar
simon_w

9 March 2008 at 3:02pm Forum Moderator, 474 Posts

I think that this works in 2.2.2.

Avatar
TF

10 April 2008 at 6:37am Community Member, 10 Posts

Just logged in to find the answer to that... no way to go around it?

Avatar
asfahaan

12 April 2008 at 9:10am Community Member, 6 Posts

I will queue behind you guys! I wanted to know as well, what is the best way to use iframes in SS.

Avatar
asfahaan

12 April 2008 at 6:48pm (Last edited: 12 April 2008 6:51pm), Community Member, 6 Posts

There is a thread which talks about an iFrame module. It works really well and will sort you guys out, like it did for me!!!

You can iFrame module here: http://devwisdom.googlecode.com/files/iframe-0.1.zip

Thread link: http://www.silverstripe.com/extending-hacking-silverstripe-forum/flat/17884?showPost=55805