Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Error when installing 2.0.1rc4 on Linux


Reply

8 Posts   2357 Views

Avatar
Blackie

5 April 2007 at 3:47pm Community Member, 4 Posts

I tried installing the latest 2.0.1rc4 on a RedHat Linux server and got the following error:

Fatal error: Call to undefined function mb_http_output() in /home/username/public_html/sapphire/main.php on line 10

Also, I have mod_rewrite successfully working on the server (I have other sites running on the server in virtual host accounts that use mod_rewrite with no problems). But I had to fast-forward past the mod_rewrite check page because it didn't recognize that mod_rewrite was working on the server. I used 2.0.1rc4 because 2.0.1rc3 had the same mod_rewrite error but I couldn't fast-forward past it.

Environment: RedHat Fedora3, Apache 1.3.37, MySQL 4.1.21, PHP 5.1.6. I've tried setting the permissions for /public_html to be owned by the apache user, the account user, chmod 755, chmod 777, etc., all the usual stuff.

Has anyone else had this problem? Or maybe a solution (some file that isn't being included properly or a permissions problem or something?)

Thanks! :)
Alex

Avatar
Andy

5 April 2007 at 4:36pm 230 Posts

Sorry, silly mistake that somehow slipped through..

Change

if('mb_http_output') {

to

if(function_exists('mb_http_output')) {

in sapphire/main.php line 9.

Also, I'm interested about the mod_rewrite check. Do you require any sort of authentification on your system?

Avatar
Sigurd

5 April 2007 at 7:48pm Forum Moderator, 628 Posts

Blackie, we've patched this minor fix (which will ensure lots more people have fussfree installations...);

See http://www.silverstripe.com/general-discussion/flat/747#post747

Avatar
Blackie

5 April 2007 at 9:19pm Community Member, 4 Posts

Hi!

Andy: No, no authentication needed on this account. I downloaded the new rc5 (I missed your reply for some reason, probably a Firefox cache thing...) I have AllowOverride set to All globally in httpd.conf, plus I added an entry specifically for this virtual domain directory.

Sigurd: This worked perfectly! Installation took about 15 seconds, including copying all the files to the userdir!

Can't wait to get working on testing this baby out!! :)

Alex

Avatar
Sigurd

5 April 2007 at 9:27pm Forum Moderator, 628 Posts

Awesome. Put your work in the showcase when you get to that point, and let us know if get any insight into why the modrewrite test was sending a false negative.

Avatar
Blackie

5 April 2007 at 9:35pm Community Member, 4 Posts

Will do. I'm impressed with the installer. I had to reinstall my Windows on my desktop this week, and compared to any programs I had to reinstall, this was easier and quicker than any of them!

Avatar
pouderStream

7 April 2007 at 5:11am Community Member, 33 Posts

Hey guys I'm back ;)

RC5 still gives the mod_rewrite error.

Avatar
Sigurd

12 April 2007 at 6:15pm (Last edited: 12 April 2007 6:16pm), Forum Moderator, 628 Posts

Heya poudersteam, did we get to the bottom of your mod_rewrite problem?
(I don't think anything in RC6 would have fixed this issue, afaik)