Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Images Show Up Compressed


Go to End
Reply


16 Posts   109657 Views

Avatar
pdpjeopardy

Community Member, 1 Post

21 March 2008 at 8:01am

Hi all! I'm neew to the forums but i've been using silver stripe for a couple monthes now. I have a few questions if anyone can help:

When I upload an image via the admin upload page, everything is fine, the image looks good, etc. But when I go to place it in a page, the image somehow gets dithered like it's filesize and quality got compressed or something. The images i'm using are jpegs and gifs. Is there anyway to keep the image quality the same?

And one last question, wheres the line of code located that allows you to see the acrobat, word, excel, zip icons when you post a link to download one of those. I notice those icons disappear when you change template and whatnot.

Any help would be appreciated!

Thanks!

Avatar
Willr

Forum Moderator, 5513 Posts

21 March 2008 at 2:11pm

"And one last question, wheres the line of code located that allows you to see the acrobat, word, excel, zip icons when you post a link to download one of those. I notice those icons disappear when you change template and whatnot. "
--

The CSS is in blackcandy/css/typography.css and the images are in images/icons/ or something like that.

If you just upload and then insert a image it shouldn't look too bad. Have you edited the image at all? Resizing and Resaving the image (if you are using the image editor) will result in a lost of quality.

Avatar
Delphinus

Community Member, 22 Posts

17 May 2008 at 2:12pm

I too would like the ability to tell SS not to reduce the image quality. I have found a hack over at http://www.silverstripe.com/site-builders-forum/flat/28159 but editing GD.php would need to be done every SS upgrade... A cleaner solution would be handy.

Avatar
Liam

Community Member, 470 Posts

25 July 2008 at 9:46am

I've edited the gd.php file and set the quality to 100 for testing purposes, and the image still shows up compressed.

The original image is 62kb and looks fine after I upload it. I then insert the image into the content area via tiny_mce and the image shows up VERY compressed with a file size of 19kb.

Has this worked for anybody? Is there anything else I can try? This is becoming a big problem and I need a fix.

Avatar
Delphinus

Community Member, 22 Posts

25 July 2008 at 10:27am

I can confirm that it worked for me with a setting of 90. Have you tried uploading a new image after making the change?

Avatar
Liam

Community Member, 470 Posts

25 July 2008 at 10:39am

Hmmm thanks for the feedback.

I've reuploaded the gd.php file many times, trying both 90 and 100 with the exact same result in the image. I've deleted the image and tried reuploading it many times, but still nothing. The original is fine, it's just when I insert it into the content area of a page it becomes resampled, therefore compressed.

I thought it was a cache issue, but I've disabled the cache, closed the browser etc and still nothing.

I guess I'll keep digging and see what I can find. Sigh. 62kb to 19kb is a HUGE compression, so you can imagine how bad the image looks.

Avatar
Delphinus

Community Member, 22 Posts

25 July 2008 at 10:49am

But have you uploaded a *new* image one that you have never uploaded before?

Avatar
Liam

Community Member, 470 Posts

25 July 2008 at 11:09am

Edited: 25/07/2008 11:11am

Yup, just tried one now and another problem I found.

I tried inserting the image I use in the header, so I could compare the two on screen. The image is 662px, and when I uploaded it and inserted it into the content area, it resized it to 600px. Nowhere in the template am I resizing the image, so is this normal?

The originally image I tested wasn't resized, because it was a smaller image, but I'm curious as to why I'm losing 42px in ratio.

I also tried deleting the images in the cache folder, and also flushing the image cache by /images/flush but there was nothing to update. Figured it was worth a shot.

Go to Top