Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Trying to Install Silverstripe - Install.php errors


Reply


4 Posts   2122 Views

Avatar
the46canadian

Community Member, 4 Posts

27 March 2008 at 7:04am

I'm trying to install Silverstripe, but at the top of the installer screen, I keep getting the same three errors:

Warning: session_start() [function.session-start]: open(/tmp/sess_145a99cedbf3464878d1975535478a1d, O_RDWR) failed: Permission denied (13) in /home/.../public_html/install.php on line 10

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/jamesshe/public_html/install.php:10) in /home/.../public_html/install.php on line 10

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/jamesshe/public_html/install.php:10) in /home/.../public_html/install.php on line 10

I've checked the install.php file for problems, and I've tried creating my own php.ini file to try and circumvent these problems - none of this has worked. Does anybody know how to solve these errors?

Thanks a lot.

Avatar
johnsoncraigsbc

Community Member, 5 Posts

27 March 2008 at 1:58pm

Check if you're running PHP 5.0 or higher.

Avatar
the46canadian

Community Member, 4 Posts

27 March 2008 at 2:10pm

According to my phpinfo.php file, I'm running PHP version 5.2.5.

Avatar
the46canadian

Community Member, 4 Posts

27 March 2008 at 2:24pm

Those errors worked themselves out, but now two more have popped up:

mod_rewrite doesn't appear to be working. Make sure:

mod_rewrite is enabled in your httpd.conf
AllowOverride is enabled for the current path.

Does anyone know where to find the httpd.conf file and what script to write to enable mod_rewrite? I've also tried entering AllowOverride All into my .htaccess file, but this causes an Internal Server (500) Error. Is there another way to enable Allow Override?

Thanks for your help!