Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

I can not install silverstripe on Unix server


Reply


7 Posts   16213 Views

Avatar
vinz

Community Member, 13 Posts

8 April 2008 at 1:27pm

Hi there,
I tryied many times to install silverstripe on unix server but I allway get fatal errors:

Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating '.htaccess' file...
Building database schema...
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 232 bytes) in /home/vinzenzf/public_html/bb/sapphire/forms/LookupField.php on line 44

I do not have any idea. Could someone help me out with this issue?

Thx

Vinzenz

Avatar
Willr

Forum Moderator, 5513 Posts

8 April 2008 at 2:25pm

You have not set the memory limit high enough for installation. The docs suggest 32mb but for resource intensive process's (like installing) this is usually not enough. If you up the memory limit to 48 or 64mb it should install fine. I run all my SS Sites with 128mb and they still run out of memory sometimes.

This is a known issue and it is down for investigation in for the future releases.

Avatar
blake

Community Member, 4 Posts

9 April 2008 at 4:02am

Im also getting this message:
Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 4864 bytes) in /customers/memaa.net/memaa.net/httpd.www/silverstripe/sapphire/forms/CustomRequiredFields.php on line 14

I can't edit php.ini because the host will not allow it, but i've tried to pu "ini_set('memory_limit', '64M');" in the top of install.php and sapphire/main.php.

Is there something i've forgot?

Avatar
vinz

Community Member, 13 Posts

9 April 2008 at 11:13am

Hi Blake,
i could fine a solution to my problem...you have you change setting in the php.ini file and copy it in the root.
Hovewer it youl be nice if there is a php.ini file set up with the right settings for silverstripe, maybe someone else have a nice file. It works but i still have 2 little error but everything works right but I would like to solve them.
Some ideas???

Vinz

Avatar
Willr

Forum Moderator, 5513 Posts

9 April 2008 at 11:20am

vinz - but i still have 2 little error.

what are these errors?

Blake - Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 4864 bytes) in

Means that you only have 16mb of memory, your host has probably disabled ini_set feature of php. Check with your host for the best way to up the memory to 32mb+

Avatar
mbellino

Community Member, 32 Posts

28 April 2008 at 7:43pm

Hey,

I have the same problem.

The hosting provider increased the php memory limit 32MB (for shared hosting they can't provide more than that - answer from support)

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 232 bytes) in ............./test/sapphire/forms/NoScriptField.php on line 14

Though the server requirements says at leasts 32MB it doesn't work
At leasts should mean that it works with this minimum requirements!

Any idea how to fix this problem? I can't request more memory, and my customer wouldn't change the hosting provider :-(

Thank you

Mario

Avatar
stooni

Community Member, 89 Posts

29 April 2008 at 3:06am

Hello my Provider is in the Memory Limit better my phpinfo says

memory_limit 64M

perhaps change the Provider !!!

stooni!!!