Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

First visit delay loading


Reply


5 Posts   1248 Views

Avatar
fordy

Community Member, 46 Posts

11 April 2008 at 12:03am

This is a trivial point i know.

A client has asked me about the 1 - 2 second delay when initially visiting the SS based website. SS is quite heavy in places that i already know about. We were having problems with the max memory allowed bug. We successfully solved by reducing the BrowseCap.ini file that is loaded from Sapphire->Misc into silverstripe-cache. I think the file is still causing to much memory overheads though.

Is the BroweCap.ini file only used for Stats? I don't really use the built in stats because we use google analytics instead. Is there anyway to disable the stats and negate the need for the chunky stats array in the file?

If the Stats is not the problem, does anyone know of any ways of streamlining the memory load on the site?

Avatar
Liam

Community Member, 470 Posts

11 April 2008 at 4:18am

See this topic - http://www.silverstripe.com/site-builders-forum/flat/40525 for disabling stats.

Avatar
Willr

Forum Moderator, 5513 Posts

11 April 2008 at 5:48pm

Stats is going to be an optional module in the next release. This should solve alot of memory issues! - http://open.silverstripe.com/ticket/2145

Avatar
fordy

Community Member, 46 Posts

11 April 2008 at 6:03pm

Thanks LeeUmm and willr.

I will instate the dirty hack for the time being.

Just out of curiosity, do you know when will we be seeing the next release?

Avatar
Blackdog

Community Member, 156 Posts

14 April 2008 at 3:16pm

Edited: 14/04/2008 3:17pm

what about the admin section, I find it is a pretty big load the first time you load it.