Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

i18n is far from normal. When?


Go to End
Reply


12 Posts   3981 Views

Avatar
soswow

Community Member, 1 Post

11 April 2008 at 10:27pm

Hello. I am fun of SilverStripe! =) I like this product very much and I see in SS big future!
But.
I am Russian and I live in Estonia, where many many other Russians. And almost all our sites are translated in at least 3 languages (Rus,Est,Eng) And this why when I make new project with SS I very need to have everything work well with translations and such stuff.
I did found lot of!! bugs and I know that you know some of them, but it seems to me, that i18n things are have low status of importance to dev team =( And this is very sad, because without normal working of i18n stuff for me using SS is almost useless.

And my question is: When You start to make changes in this way?

From my side I will try to find all of bugs I could find and report it to the Bug Base.
(One is already there for milestone 2.3)

Avatar
lekoala

Community Member, 30 Posts

12 April 2008 at 12:37am

I fully agree with you on this one :) I'm from Belgium which means that I make websites in French, Dutch and English ... I hope the version 2.3 will fix most of the problems that exist currently :-)

Avatar
Ingo

Forum Moderator, 801 Posts

12 April 2008 at 1:10pm

we're partially relying on the community to help us out here - silverstripe (the company) has limited ressources. reporting bugs is a good first step, but essentially we need external developers to contribute to features they like to see implemented, and bugs they like to see resolved.

Avatar
Sam

Administrator, 685 Posts

17 April 2008 at 11:03am

Thanks for offering to report i18n bugs, soswow. This will help us to iron out these problems.

Avatar
Fabie

Community Member, 28 Posts

9 September 2008 at 1:06pm

Hello,
I am also having a lot of issues, especially with the translation into English from default language....
Could anyone recommend the best, most stable silverstripe version to use languages? I really need help with this as the site is live and it is not working.

For instance, when I am creating a new page in English (default language is de_CH) it actually changes the URL of the default language !

Anyone knows how I can fix this bug?

Avatar
Willr

Forum Moderator, 5513 Posts

9 September 2008 at 11:10pm

The major project that we have actually used i18n with is demconvention.com and all these changes are on a custom branch I would assume and are yet to be merged back into the trunk version of SilverStripe. Hopefully when the changes have be merged back into the public release it will fix quite a few of these issues

Avatar
Fabie

Community Member, 28 Posts

10 September 2008 at 6:13pm

Hello, well after trying for hours to see what was wrong with the locale and i18n, DesignCity gave me all the tips I needed (THANKS!). Since I am sure I am not the only one in the same situation, here is the scenario (it is currently running on 2.2.1).

1) NEVER EVER EVER have the website and SilverStripe opened in the same browser (i.e. using tabs) as when you change the language on the site it changes it on silverstripe and vice versa, without you knowing it. This means that it you will need two browsers, one for the site, one for SilverStripe. I know its not the easiest option (especially getting your clients to install a second browser) but it will save you a lot of headaches.

2) Use individual URLs to avoid errors (so if you have the same word in the url eg.www.mysite.com/product make one /product-en for example)

3) When you publish a translated page, also publish the corresponding page in the default language.

4) refresh the CRM a lot

For some reason i am sure Willr will want me to put this on the wiki ;-)

Fabie

Avatar
Skipper

Community Member, 16 Posts

10 September 2008 at 7:40pm

I am still waiting to hit the wall. I am busy building a three language site (EN, DE, FR) and am happy so far. I have written a small hack to have pretty URLs and mysite.com/en/products mysite.com/de/produkte and mysite.com/fr/produits works just fine in conjunction with a menu that shows the language offers. Well, it works as far as I can tell.

So my question to this thread is: What are the problems you have? I'd be curious to have them before my client encounters them.

Thanks a ton!

Go to Top