Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Uploading (gallery) doesn't work anymore in 2.2.2rc2


Reply


4 Posts   1370 Views

Avatar
Jan

Community Member, 9 Posts

14 April 2008 at 2:36am

Hi,

uploading of images and video's worked in 2.2.1 (in IE and FF). Then I installed 2.2.2rc2 in a new directory with the Gallery and Blog modules. Installation went fine. Blog works.

I then inserted a Gallery page and tried to upload a image and/or video. Both didn't work. Not in FF and not in IE. You see the progress bar growing to the end and then nothing. In the older version you would then see a message below saying '1 file uploaded' and the upload tab would refresh.

I checked the assets\Uploads directory but the uploaded files were not there.

So uploading fails. What gives?

Avatar
Jan

Community Member, 9 Posts

14 April 2008 at 2:59am

I updated the SWFUpload component to 2.0.2 and then 2.1.0.beta2 from http://code.google.com/p/swfupload/
I copied it to ...\jsparty\SWFUpload

With these versions uploading worked. Although the progress didn't. But I got the message saying '1 file uploaded' and the file showed up in the gallery!

Hopefully with the final release of 2.2.2. this component is also updated.

Avatar
Sam

Administrator, 685 Posts

14 April 2008 at 10:10am

Hi Jan,

We upgraded SWFUpload in 2.2.2-rc3. Can you test this RC and raise a ticket on http://open.silverstripe.com if it doesn't work?

Avatar
Jan

Community Member, 9 Posts

14 April 2008 at 7:26pm

Ok it works in rc3. The progress bar works and the file shows up in the uploaded directory and I can insert it in for example my homepage.