Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Tag search in blog module


Reply


5 Posts   1933 Views

Avatar
Nathan Cox

Community Member, 99 Posts

18 April 2008 at 12:36pm

Hi, I noticed on the demo site that the URL for 'search by tag' in the blog modules is like /blog/tag/silverstripe, but on my install the URLs are generated as /blog/?tag=silverstripe, and if I go to /blog/tag/silverstripe I get a blank white page. Does anyone know why? Is there some configuration or something I'm missing? I'd like to have the /blog/tag/silverstripe URLs if possible...

Avatar
Willr

Forum Moderator, 5513 Posts

18 April 2008 at 5:41pm

seems like you dont have mod_rewrite property installed?

Avatar
Nathan Cox

Community Member, 99 Posts

18 April 2008 at 6:06pm

No, all my other URLs are working fine...In fact, what seems to be happening is that everything is being processed properly, and it's calling the BlogHolder::Tag(), which only returns a boolean instead of viewable data, hence the blank page. From what I can tell that's all working fine and the real question is, why doesn't the demo blog behave like that? Has is been modified?

Avatar
Willr

Forum Moderator, 5513 Posts

18 April 2008 at 6:12pm

the demo blog is on a pretty early version of the blog I would say. Are you running off trunk?

Avatar
Nathan Cox

Community Member, 99 Posts

18 April 2008 at 6:15pm

I just got 0.1 from the downloads page...I guess I can always just hack it to give the BlogHolder_Controller a Tag() method?