Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Can't make sense of the content translation feature


Reply


859 Views

Avatar
Maxim

Community Member, 6 Posts

24 April 2008 at 5:56pm

Hi, I'm trying to create a simple multilingual site (with French and English), but I can't see how to do it. I have followed these instructions to enable i18n and update the database schema, and it seemed to work fine:
http://doc.silverstripe.com/doku.php?id=multilingualcontent&s=language

A "Translations" tab appears when I edit a page in the CMS, and this gives me an option to "Create new translation".

When I select French, and press the "create" button, silverstripe says "WARNING: Your changes have not been saved". I press OK, and a small dropdown list appears in the Site Content section, giving me a choice between French and English.

While I'm in French mode, I can click on an existing page, and it asks "Would you like to start a translation for this page?" But when I click "OK", it seems to create a completely separate page for the translation. It doesn't seem to be linked to the original page at all, and all of the French and English pages are mixed together in the site content list. For example, I have a "Home" page and a separate "Accueil" page.

Surely the pages should be linked together, so we can know when one is a translation of another? Am I just missing something obvious?

Btw - I am using version 2.2.2-rc3.

Thanks,
Maxim