Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Cannot login after installation


Reply

8 Posts   9072 Views

Avatar
Kim

20 April 2007 at 1:58am Community Member, 5 Posts

Hi,

I just installed SilverStripe (and it said it was successful after I met all the requirements for installation). I cannot login however. I've looked at the Member table in my database and can see the username and password I selected, and can even copy & paste directly from the db (since the password isn't encrypted) but everytime I try to login I get the following error message:

I'm sorry, but you can't access that part of the CMS. If you want to log in as someone else, do so below

Any suggestions on how to get past this?

Avatar
SLJ

20 April 2007 at 3:48am Community Member, 23 Posts

I'm fairly new at this myself, but I had a similar problem on my first local install. If I remember correctly it happened after changing from the default password. I think what I had to do was use the flush command on the URL, and then it worked.

I don't know for sure if this will help you but if it does it would be a quick fix and worth a try.

Hope this helps.

Avatar
Kim

20 April 2007 at 6:54am Community Member, 5 Posts

I tried the flush command, that didn't work. :/

I deleted my site cookies and when I tried logging in again it welcomed me as Admin but there were no links anywhere on the page, it simply said: "You're logged in as Admin." in red and beneath the message was the email/password login boxes again.

After that I tried to go to a CMS management url, like mysite.com/admin or mysite.com/admin/assets and it just tells me "you can't access that part of the cms", same as the previous error.

I have changed the permissions of the "mysite" folder to be owned by nobody and writable by nobody, but alas, no luck.

I really, really liked the looks of Silverstripe, but with a time crunch on the project I may have to go to another one just to get it done if I can't get past this initial hurdle (a real drag 'cause it looked about perfect).

Avatar
SLJ

20 April 2007 at 7:34am Community Member, 23 Posts

It's a really great CMS. Hang in there. Someone will be along who can give you better answers. I'm too new at it to be really helpful.

I was also concerned about not being able to use it because of initial problems and my project deadline. Once you get over the hurdles though, it is so worth it! So much so that I moved the project to a new host with better support for PHP 5.

Try the IRC channel. Someone may be on there who can help you right now.

Avatar
Andy

20 April 2007 at 9:24am 230 Posts

Which version of PHP are you using? Someone had this issue on PHP 5.0.5, and it is fixed in the daily build so you might wanna try that and see how you get on.

http://dailybuilds.silverstripe.com/tarballs/silverstripe.2.0.DailyBuild.2007-04-19.tar.gz

Avatar
Kim

20 April 2007 at 9:37am Community Member, 5 Posts

I was planning to purge it all and start fresh so I'll do that with daily build you mentioned and let ya know. Thx!

Avatar
Kim

21 April 2007 at 4:52am Community Member, 5 Posts

Okay! I'm in. I dropped the database from my first installation, recreated it, and wiped out the contents of the httproot folder and started anew... and it worked with yesterday's daily build. :)

Thanks!

Now I'm onto a whole other challenge -- creating my own template(s) :)

Avatar
Sean

21 April 2007 at 8:27am Forum Moderator, 921 Posts

Great. Good luck, if you get stuck with anything further don't hestitate to post on this forum. :-)

Cheers!
Sean