Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Ongoing errors...


Go to End
Reply


12 Posts   29069 Views

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

2 May 2008 at 10:18pm

Edited: 03/05/2008 5:30pm

Hi,

I am a first time user of SilverStripe, well, I havent actually managed to get it installed yet, so havent even used it...

I have no problem on my server with other CMS software running PHP5+ and MySql, so I am not sure how to solve this SilverStripe install error.

After downloading then uploading all the files (twice) to my server and setting up the install, it simply gets stuck on building the database schema. There is no errors that are shown (with display errors on in php.ini), the browser stops processing, I have my php memory_limit set to 32M then 64M and everything had the green light during the setup.

Looking at my server log, this is what it contains:

[Fri May 02 20:07:09 2008] [error] [client 222.154.8.18] PHP Warning: is_dir() [<a href='function.is-dir'>function.is-dir</a>]: open_basedir restriction in effect. File(/var/www/vhosts/andy.net.nz/httpdocs/../) is not within the allowed path(s): (/var/www/vhosts/andy.net.nz/httpdocs:/tmp) in /var/www/vhosts/andy.net.nz/httpdocs/sapphire/core/ManifestBuilder.php on line 93, referer: http://www.andy.net.nz/install.php
[Fri May 02 20:07:09 2008] [error] [client 222.154.8.18] PHP Warning: is_dir() [<a href='function.is-dir'>function.is-dir</a>]: open_basedir restriction in effect. File(/var/www/vhosts/andy.net.nz/httpdocs/..) is not within the allowed path(s): (/var/www/vhosts/andy.net.nz/httpdocs:/tmp) in /var/www/vhosts/andy.net.nz/httpdocs/sapphire/core/ManifestBuilder.php on line 111, referer: http://www.andy.net.nz/install.php
[Fri May 02 20:07:09 2008] [error] [client 222.154.8.18] PHP Warning: is_dir() [<a href='function.is-dir'>function.is-dir</a>]: open_basedir restriction in effect. File(/var/www/vhosts/andy.net.nz/httpdocs/../) is not within the allowed path(s): (/var/www/vhosts/andy.net.nz/httpdocs:/tmp) in /var/www/vhosts/andy.net.nz/httpdocs/sapphire/core/ManifestBuilder.php on line 133, referer: http://www.andy.net.nz/install.php
[Fri May 02 20:07:09 2008] [error] [client 222.154.8.18] PHP Warning: require_once(Auth/OpenID.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: No such file or directory in /var/www/vhosts/andy.net.nz/httpdocs/auth_openid/code/Auth/OpenID/Consumer.php on line 163, referer: http://www.andy.net.nz/install.php
[Fri May 02 20:07:09 2008] [error] [client 222.154.8.18] PHP Fatal error: require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'Auth/OpenID.php' (include_path='.:') in /var/www/vhosts/andy.net.nz/httpdocs/auth_openid/code/Auth/OpenID/Consumer.php on line 163, referer: http://www.andy.net.nz/install.php

Please advise on the method of fixing this, I feel unfortunate that my first experience with SilverStripe is a negative one, but being a Kiwi, I am willing to put in some time to get the thing running... logged 3-4 hours so far searching and trying to fix myself...

Thanks in advance,

Andy

Avatar
Willr

Forum Moderator, 5513 Posts

2 May 2008 at 10:26pm

open_basedir restriction in effect.

Sounds like your running PHP in safe mode, there was a bit of work done recently to make sure installation on safe systems worked but this might be another issue with it. Do a search round the forums for safe mod, maybe someone has fixed / got a patch for this sort of error.

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

2 May 2008 at 10:27pm

Thanks for the quick reply. The domain has PHP Safe mode turned off.

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

2 May 2008 at 11:16pm

I ended up downloading and installing v2.2.2-RC3 which installed fine... so I guess its an issue with the 2.2.1 files...

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

2 May 2008 at 11:42pm

Edited: 03/05/2008 12:31am

Now getting the following error:

Warning: require_once(Auth/OpenID.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/vhosts/andy.net.nz/httpdocs/auth_openid/code/Auth/OpenID/Consumer.php on line 163

Fatal error: require_once() [function.require]: Failed opening required 'Auth/OpenID.php' (include_path='.:') in /var/www/vhosts/andy.net.nz/httpdocs/auth_openid/code/Auth/OpenID/Consumer.php on line 163

Which was solved by deleting the auth_openid folder...

Then came up with more errors when tying to change themes, so I reinstalled 2.2.3, but get this error...

Notice: Undefined variable: mem in /var/www/vhosts/andy.net.nz/httpdocs/install.php on line 639
# Creating /var/www/vhosts/andy.net.nz/httpdocs/mysite/_config.php
# Creating '.htaccess' file...
# Creating /var/www/vhosts/andy.net.nz/httpdocs/.htaccess
# Building database schema...

Fatal error: Declaration of Order_Item::__construct() must be compatible with that of DataObjectInterface::__construct() in /var/www/vhosts/andy.net.nz/httpdocs/ecommerce/code/Order.php on line 1107

I've never had so much trouble...Although SS looks really promising, it installs like a warm turd on a cold day...

Avatar
Willr

Forum Moderator, 5513 Posts

3 May 2008 at 11:48am

Edited: 03/05/2008 11:49am

Fatal error: Declaration of Order_Item::__construct() must be compatible with that of DataObjectInterface::__construct() in /var/www/vhosts/andy.net.nz/httpdocs/ecommerce/code/Order.php on line 1107

Try and install SS standalone first (without ecommerce) so you can get that up and running and then add in the modules. I always find that easier to do. Make sure you are using trunk for ecommerce as thats probably your best bet for SilverStripe 2.2.2 support. Im pretty sure Romain is doing alot of development on ecommerce trunk at the moment (see http://open.silverstripe.com/browser/modules/ecommerce/trunk) and he would be working with 2.2.2 of SS so it should be working fine with that.

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

3 May 2008 at 3:51pm

Thanks Will.

I have the daily SS build running ok now, 2.2.3RC3 (2/05/08) or whatever its up to.. Ive just checked-out the files from SVN, and have to get around to updating the ecommerce module...

I was looking through the documentation, but whats the quickest and easiest way to add access to the modules via the backend. I am use to joomla, wordpress, and pretty much everyother CMS where you simply have a modules section or manager for activating/deactivating modules. Basically installing all the standard modules, and need to get them all up and running with access via admin panel.

Cheers,

Andy

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

3 May 2008 at 4:14pm

Edited: 03/05/2008 5:31pm

Using the latest SVN download of the ecommerce module fixed the install db-build errors. But still issues actually viewing the ecommerce section inbrowser...

Fatal error: Call to undefined method Order::shoppingcart() in /var/www/vhosts/andy.net.nz/httpdocs/ecommerce/code/ProductGroup.php on line 34

Can someone tell me what version of SS they have running with what versions of the modules? Nothing seems to work properly at all... too much of a hack job to get this CMS running for clients...

Go to Top