Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

mod_rewrite problem


Reply


4 Posts   2178 Views

Avatar
desperados

Community Member, 3 Posts

3 May 2008 at 9:03pm

silverstripe 2.2.1 (stable?????)

i've tried on pampa, easyphp2, and apache2 on debian
it doesn't work !!!!

all time the same error:

mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway. <http://localhost:8080/test/cms/silverstripe2/rewritetest.php?force=1>

but mod_rewrite is loaded and AllOverride is "all"

Avatar
Invader_Zim

Community Member, 141 Posts

4 May 2008 at 7:10am

Edited: 04/05/2008 7:11am

Hi,

i had the same problem with 2.2.1 stable and my Webhoster (DomainFactory).

But after adding the line: RewriteBase "/" in my .htaccess file, everything seems to work now!

So maybe that was of help to you...

Avatar
desperados

Community Member, 3 Posts

4 May 2008 at 7:19pm

noway :(

Avatar
desperados

Community Member, 3 Posts

4 May 2008 at 7:43pm

resolved!

sorry, my fault.

in httpd.conf of easyphp2 there are 2 parameters to modify:

DocumentRoot "${path}/www"
<Directory />
Options FollowSymLinks
AllowOverride all
Order deny,allow
Deny from all
Satisfy all
</Directory>

and

<Directory "${path}/www">
Options Indexes FollowSymLinks
AllowOverride all
Order allow,deny
Allow from all
</Directory>

one more thing: i've downloaded the windows autoinstall version, and the upload of images doesn't work.