Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.


Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Exclude pages from sitemap.


6 Posts   41317 Views


6 May 2008 at 9:26pm (Last edited: 6 May 2008 9:26pm), Community Member, 53 Posts


how do I exclude certain pages or folders from the sitemap (generated as in tutorial #6). For example, I have a site recently built at, which uses a folder named "banners" to display the 4 banners at the frontpage. I don't want those to be shown in the sitemap (, but I don't know how to exclude them. Any ideas?



7 May 2008 at 12:55am Community Member, 89 Posts

I think you can in the Page Register Behavior clicking and remark "In the search ads?" and View in Menus then these files also disabled for sitemap?

I'm not shure, because i think so !!!



7 May 2008 at 1:09am Community Member, 53 Posts

I have already deselected both "Show in menus" and "Show in search" on each file and the folder the files are placed in, but they still show up in the sitemap.


7 May 2008 at 4:46am Community Member, 470 Posts

The newer versions of SS come with a sitemap feature built in, so you don't have to use the tutorial any more.

There is a bug with the feature to exclude certain pages from the sitemap. It isn't working correctly as even if you specifically select "not indexed" under the meta-data -> advanced options, it still shows up.

There is a ticket in the trac for milestone 2.2.3


7 May 2008 at 5:02am (Last edited: 7 May 2008 5:02am), Community Member, 53 Posts

The site is built on SS 2.2.1, is the "not indexed" functionality in 2.2.2? Anyway, since you say it's not working, and there's a ticket in the trac, I guess I'll just have to wait for the next release. Not a big issue. Thanks for the help!


7 May 2008 at 8:57am Community Member, 470 Posts

I think there is even the built in sitemap with 2.2.1, so you could use that by default and clean up some extra code.

However, the not indexed function doesn't work. I was the one who opened the ticket cause I ran into the same problem as you. I was hoping it would be fixed by 2.2.2 final, but they moved it to 2.3. I made a mistake in my first post about thinking it was set to 2.2.3.