Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Image upload only works in IE


Go to End
Reply

9 Posts   138255 Views

Avatar
manafta

11 May 2008 at 9:57pm Community Member, 7 Posts

The image upload only seems to work with Internet Explorer (I am using IE7).

In other browsers I get the message "Files ready to upload" with a list of images. But nothing happens when I click on "Upload files listed below".

If I am using TinyMCE, I only get the message "Uploading ... 1/1".

Tested it with:
- Firefox 2.0.15 (Windows/Linux)
- Opera 9.27 (Windows/Linux)
- Safari 3.1 (Windows)

Using Flash version 9.0 and Silverstripe 2.2.1 and 2.2.2 rc3.

Avatar
chiefie

15 May 2008 at 8:13pm Community Member, 22 Posts

I'm using the Daily build 2008-05-14 since the stable version doesn't install properly on Web Drive. Anyhow, I have file upload problem too, as it seems like nothing is being uploaded. Creating folder is fine.

Avatar
Berteh

21 May 2008 at 10:41pm Community Member, 11 Posts

I could upload images on my localhost (running XAMPP 1.6.4, e.g. php 5.2.4, on ubuntu) with firefox, while I could not upload anything on my public host (runnning php 5.2.6)... folder creation worked in the 2 cases.

The file & folder permission seems right on both configurations, both running Apache2.

Hope this helps fixing this problem :/

Avatar
manafta

22 May 2008 at 9:20am Community Member, 7 Posts

The problem is flash player 9.0.124. Downgraded to 9.0.48 and now it works.

Avatar
chiefie

22 May 2008 at 4:20pm Community Member, 22 Posts

Is SWFUpload the only the solution to use for uploading?

It is one thing to downgrade to older version of Flash will help (haven't tested myself), but you surely cannot expect all my authors to downgrade their Flash to older version, or even the other site users to downgrade to older version of Flash when using public accessible uploading function?

Anyone know what is changed between the 9.0.124 and 9.0.48?

Avatar
Tim

22 May 2008 at 5:30pm Core Development Team, 201 Posts

There seem to be a number of problems with the SWFUploader, so we've decided to remove it from the core for the final release of 2.2 which is arriving very shortly...

Hopefully these issues with the SWFUploader will be resolved in a few months so we can included it again for the next release of SilverStripe.

Avatar
chiefie

22 May 2008 at 7:23pm Community Member, 22 Posts

So... what will be replacing SWFUpload (don't suggest FTP)

Avatar
chiefie

22 May 2008 at 8:04pm (Last edited: 22 May 2008 8:06pm), Community Member, 22 Posts

Ok... I've installed the 2.2.2 version (22 May 08) and the upload works! YAY!

Go to Top