Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Noob problem with Gallery


Go to End
Reply


9 Posts   3629 Views

Avatar
bones

Community Member, 104 Posts

16 May 2008 at 4:21am

Edited: 16/05/2008 4:23am

Hello

I only started using Silverstripe about a week ago, and it's gone pretty smoothly so far, so I'm astonished (and somewhat embarrased) that I can't figure out how to use the gallery module.

I've followed the documentation, installed it, got all of the tabs and things up and running, but just don't seem to be able to do the final bit.

I've..

- Added an extension, selected filetype and uploaded a default icon
- Ticked the extension in the list, and pressed "save"
- Selected the folder to show the images from, under the "files" tab

Erm.. then what?

All help gratefully recieved.

Thanks

John-Lee

Avatar
stooni

Community Member, 89 Posts

16 May 2008 at 11:28am

Testing with IE perhaps is going i think is a ticket open, the other way you upload Files via a php fileuploader and then you must set chmod 777 , in the silverstripe you must go to files and first view the files in sst filemanager, then you can see and put in your site in the browser!!!

i hope these will help!!

---- Stooni

Avatar
bones

Community Member, 104 Posts

16 May 2008 at 8:25pm

Thanks, stooni.

I've uploaded the pictures, but how do I actually get the Gallery onto the page?

John-Lee

Avatar
stooni

Community Member, 89 Posts

16 May 2008 at 9:17pm

Open in the sst the filemanager and view are the files are there???

then you can get in the sst site , you must have installed the http://www.silverstripe.com/modules/ Gallery (v0.2.2)
1. dont forget the /db/build/?flush=1 and the /?flush=1
then you become a folder for the Gallery put the pictures in there and create a Gallery Site in the sst!!!

---Stooni

Avatar
bones

Community Member, 104 Posts

16 May 2008 at 9:36pm

Hi stooni

Yes, I can see the images in the "files & images" tab.

I select the Extension and click save.

When I go back to my GalleryPage, and click on the "files" tab, I select the folder that the images are in.

I've attached screen grabs.

I'm very grateful to you for your help and patience.

Kind regards

John-Lee

Avatar
stooni

Community Member, 89 Posts

17 May 2008 at 2:43am

Fine in the Tab Extensions on the gallery Site klicking the first --- png,jpg,jpeg,gif.. perhaps delete your created extension Save all und View your Gallery!!! I think its now going these point is at my site these way..

I hope it's goning now!!!

Thanks -------stooni

Avatar
bones

Community Member, 104 Posts

20 May 2008 at 1:19am

Nope.

It just doesn't want to work :(

Avatar
stooni

Community Member, 89 Posts

20 May 2008 at 6:21am

Please upload Screenshot from Site Gallery and Registercard Gallery perhaps here is something wrong!!!

---Stooni---

Go to Top