Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

1 and 1 install issue


Reply


7 Posts   4169 Views

Avatar
max74

Community Member, 3 Posts

17 May 2008 at 4:05am

Hi,

I have just come across Silverstripe and am having trouble with the installation.

I successfully downloaded the file to my web space on 1 and 1 in a folder I created as I didn't see an obvious public domain, for example public_html, so its located in one I've created. As required in 1 and 1 I have changed the destination for the domain to link to the folder created. However, when I visit the domain I get error 404.

Can anyone suggest what i am doing wrong? I also tried www.mydomain.co.uk/silverstripe/install.php and nothing happened. I'm assuming the file doesn't need extracting or anything like that in the web server as it was a simple download.

I wonder if I am supposed to include the folder name, for example www.mydomain.co.uk/folder/silverstripe/install.php. Not sure where to go from here to reach the next to the my sql set up page as outline in the tutorial. The tutorial says visit the url but what url?? I have searched the forum for help but couldn't find anything.

Any help much appreciated as I'm getting somewhat frustrated now.

Thanks

max

Avatar
spenniec

Community Member, 37 Posts

17 May 2008 at 9:02am

Hi Max,

Do you currently have a homepage for your webspace, if so what is the URL?
When you say you downloaded the file to your webspace on 1 and 1, is that the file
http://www.silverstripe.com/assets/downloads/PHPInstaller/silverstripe-v2.2.1.tar.gz
Did you unzip this file to create the directories
assets
cms
jsparty
...
etc

Avatar
max74

Community Member, 3 Posts

20 May 2008 at 12:08am

Hi,

The domain is www.vjem.co.uk. As you will see there's nothing there. I have unzipped the files to show the directories on my webserver but still can't see the install page in the browser.

I know its something simple but just can't see the problem.

M

Avatar
Jayseuk

1 Post

20 May 2008 at 3:52am

Hi,
I've just checked your site and noticed that silverstripe is installed in a sub directory here www.vjem.co.uk/silverstripe-v2.2.1

Avatar
max74

Community Member, 3 Posts

20 May 2008 at 4:39am

Wow thanks for that. I tried that url but didn't see anything. Anyway I got the message below so after all that I won't be able to use SS after all but thanks to everyone for their assistance with this.

"You need PHP version or later, only 4.4.8 is installed. Unfortunately PHP4 and PHP5 have some incompatabilities, so if you are on a your web-host may need to move you to a different server. Some software doesn't work with PHP5 and so upgrading a shared server could be problematic."

M

Avatar
Sigurd

Forum Moderator, 628 Posts

20 May 2008 at 9:57am

If that host does indeed only run PHP version 4, you will need to find a better host.

You could ask them if they have PHP5 as an option they can activate for you.

PHP 5 came out around four years ago. All webhosts should offer it.

Avatar
Webslave

2 Posts

23 May 2008 at 8:44pm

Edited: 23/05/2008 8:52pm

I'm in the same situation.
.
There are a series of things I've done so far but the installation still isnt working. Because on 1 and 1 we don't have access to the config file for PHP we use the .htaccess file. I've put this in the same folder as the CMS - I've tried it on the root but it doesnt appear to have an effect.
.
First you need to 'turn on' PHP 5. You do this by add this to the .htaccess file..
--
AddType x-mapp-php5 .php
--
You'll see the php5 problem is fixed.
.
The next problem, and one I havnt been able to overcome so far, is getting rewrite to work. I'm hoping someone can help me here. The problem is silverstripe appears to want to write it's own .htaccess file making editing this before hand tricky. Again I need help on this.
.
I've added into the .htaccess files the following additions
.
--
RewriteEngine On
RewriteBase /
Options -MultiViews
--
.
Questions.
------------

Should RewriteBase contain the folder for my cms? For example "RewriteBase /cmsfolder/" ?
.

Options -MultiViews was suggested by One and One - doesn't appear to have helped.
.

Has anyone installed silver stripe successfully on one and one UK and can help me get over my difficulties.
.

Cheers