Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

problems Saving and Publishing


Reply

7 Posts   2169 Views

Avatar
schwerd

22 May 2008 at 1:05pm Community Member, 1 Post

newbie here...installation successful according to install script.
go to do first edit...when I hit Save or Save and Publish...it just runs forever...never stops and never give error message....so I have no idea what's going on or why it's failing...the icon spins and spins and never resolves..and the Save or Publish never happen.

are there error messages somewhere??

Avatar
Willr

22 May 2008 at 8:15pm Forum Moderator, 5511 Posts

Do you have firebug installed? that would be handy for errors

Avatar
christian

22 May 2008 at 9:23pm (Last edited: 22 May 2008 9:23pm), Community Member, 6 Posts

I've had the same problem.

My solution was disabling the GoogleSitemap ping feature. When enabled, every time you hit save & publish, silverstripe sends a notice to google, so that they know to re read the sitemap.xml
In my case, the webserver, silverstripe is running on, is behind a firewall which blocks all outgoing data.
After disabling this feature in mysite/_config.php

GoogleSitemap::DisableGoogleNotification();

save & publish works fine and as fast as it should be.

Perhaps this could also be a solution for you.

Greetz

Christian

Avatar
Nadee

30 July 2008 at 5:34pm Community Member, 12 Posts

Thanks for the great question and answer. Resolved my problem.

Avatar
evren

21 October 2008 at 11:22am (Last edited: 21 October 2008 11:23am), Community Member, 37 Posts

Hi;

I need the same modification but couldnt find that string in _config.php
Is that something about my release (2.2.2) or I'll add it manually?

If yes something like that

<?php

global $project;
$project = 'mysite';

global $databaseConfig;
$databaseConfig = array(
   "type" => "MySQLDatabase",
   "server" => "localhost",
   "username" => "username",
   "password" => "password",
   "database" => "database",
);

// Sites running on the following servers will be
// run in development mode. See
// http://doc.silverstripe.com/doku.php?id=devmode
// for a description of what dev mode does.
Director::set_dev_servers(array(
   'localhost',
   '127.0.0.1',
));

// This line set's the current theme. More themes can be
// downloaded from http://www.silverstripe.com/cms-themes-and-skin
SSViewer::set_theme('blackcandy');

GoogleSitemap::DisableGoogleNotification();

?>

Thanks.

Avatar
christian

21 October 2008 at 7:06pm Community Member, 6 Posts

Hi evren,

you are right. Just put that line in your mysite/_config.php.

This feature is enabled by defaut so you will not find an entry like GoogleSitemap::enable() or so.

Avatar
evren

21 October 2008 at 10:33pm Community Member, 37 Posts

Thanks for your solution.

Maybe your firewall matter gets attentions and it will be fixed to save the page even it can ping to google or not.