Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Uploads 'first uploaded' 37 years ago


Reply


6 Posts   2963 Views

Avatar
henno

Community Member, 6 Posts

26 April 2007 at 5:55pm

Fresh install of v2.0.1

All of my uploads are not populating the date they were uploaded.

i.e. the details are as follows:

Filename
URLassets/products/image.jpg
TypeJPEG Image - good for photos
Size34 KB
Owner
Dimensions200x300
First uploaded01/01/1970, 37 years ago
Last changed24/04/2007, 3 days ago

As you can see, the 'Last Changed' date works fine, but the 'First uploaded' date is obviously not being populated in the database correctly at the point of upload.

I haven't researched any further than merely reproducing the error.

henno.

Avatar
Sigurd

Forum Moderator, 628 Posts

26 April 2007 at 9:36pm

Edited: 26/04/2007 9:42pm

I've noticed this thing in the past but didn't deem it severe enough to be fixed; I'll ensure it gets on our to-fix list :)

The error is fairly understandable... 1/1/1970 is the "beginning" of time for PHP in most situations, if you're wondering why that particular date is being shown :)

Avatar
henno

Community Member, 6 Posts

26 April 2007 at 9:50pm

Yeah I realise where the date comes from. Just not sure why it is not being populated.

You're right, it is no big deal, and in fact, I just uploaded some PDFs (as opposed to the GIFs I was uploading before) and it seems they are adopting the correct date, so who knows.

henno.

Avatar
Jedateach

Forum Moderator, 232 Posts

30 April 2007 at 2:45pm

Edited: 30/04/2007 2:46pm

It looks like this bug occurs in specific circumstances. I'm looking into it.

So far I've been able to add both jpg and gif images with the associated first uploaded date being correct.

Let me know if you find out what these circumstances are. ;)

Avatar
marc

Community Member, 2 Posts

12 September 2008 at 8:23pm

Hi!
It appears when I do some changes (like changing title) and then save.

Avatar
spark

Community Member, 15 Posts

9 October 2008 at 2:17pm

Any more info on this? I see the same problem when I update any article on my site. It changes the date to 12.31.1969. Please send any help!

Thanks,
Danielle