Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Blog Error - SS 2.2.2 - Tried all blog versions


Reply


25 Posts   11366 Views

Avatar
karibe

Community Member, 56 Posts

30 May 2008 at 9:05pm

And the error is :

Fatal error: Class 'CustomPageCommentInterface' not found in /home/.jowls/ijoga/ijoga.pl/mysite/code/Page.php on line 123

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

31 May 2008 at 6:41pm

I have an issue now that I cannot format blog entries. Using TinyMCE, it just pops up a window saying 'undefined'. It works fine on normal pages but not blog entries. I also cannot insert images. No errors come up.

Avatar
simon_w

Forum Moderator, 474 Posts

31 May 2008 at 6:46pm

Using the SVN version of the blog, you should be able to use TinyMCE by adding BlogEntry::allow_wysiwyg_editing(); to mysite/_config.php.

Note: This will break the formatting in all your current blog posts.

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

31 May 2008 at 7:30pm

I get the following error trying that:

Fatal error: Call to undefined method BlogEntry::allow_wysiwyg_editing() in /var/www/vhosts/bombr.net/httpdocs/cms/mysite/_config.php on line 30

Avatar
Willr

Forum Moderator, 5513 Posts

31 May 2008 at 7:32pm

Have you got the SVN version?

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

31 May 2008 at 7:39pm

Well I do, but where do I find the daily builds?

Avatar
Willr

Forum Moderator, 5513 Posts

31 May 2008 at 7:42pm

http://dailybuilds.silverstripe.com/

Avatar
AndyWiltshireNZ

Community Member, 35 Posts

31 May 2008 at 7:43pm

Edited: 31/05/2008 7:55pm

Gah, thanks for the help guys, I missed the db/build step..

Wow, that works so much better, images work properly and everything, can't see why BBcode was ever used for the blog...