Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Security pages blank


Reply

3 Posts   1017 Views

Avatar
HansR

5 June 2008 at 3:29am Community Member, 140 Posts

I've installed Silverstripe with a certain amount of effort. I had to add "php_flag zend.ze1_compatibility_mode Off" to the .htaccess file in order for it to get beyond "building database..." in the install process. Even after this, it complained that mod_rewrite wasn't working. Nevertheless, most of the site works.

One big issue is that clicking on items in the security page (e.g., Administrators) results in a blank page. I enabled dev mode and got the following message:
------------------------------------------------------------------------
ERROR:Error 512: None of these templates can be found: Security_getitem.ss, Security.ss
At l74 in /sapphire/core/SSViewer.php
user_error(None of these templates can be found:Security_getitem.ss, Security.ss,512) line 74 of SSViewer.php

SSViewer->__construct(Array)
line 329 of Controller.php

Controller->getViewer(getitem)
line 296 of Controller.php

Controller->defaultAction(getitem,Array)
line 267 of Controller.php

Controller->run(Array)
line 104 of Director.php

Director::direct(/security/getitem)
line 158 of main.php
------------------------------------------------------------------------

Any ideas as to why? Those template files don't exist, and my impression is that they're not supposed to exist.

Just in case they're related, I also have these problems:
- Under "files & images", clicking on "uploads" (or the upload tab) brings up a 404 error
- The widgets tab for a blog page will let me drag a new widget, but it's settings doesn't show and saving won't add the widget to the page. The next time that I go to edit the blog page, the widget that I dragged earlier does not appear in the installed list.

Hans

Avatar
HansR

6 June 2008 at 11:04am Community Member, 140 Posts

I've compared the php settings (via phpinfo()) from my webhost with a home server that did work successfully, and the only difference of note was that the problematic server has allow_url_fopen set to off. Does Silverstripe need this functionality?

I still haven't managed to find a solution.

Hans

Avatar
HansR

11 June 2008 at 12:05am Community Member, 140 Posts

Problem solved, see [url=http://www.silverstripe.com/site-builders-forum/show/84637]here[/url].

Hans