Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

2.2.1 => 2.2.2 Upgrade. CMS Error on Files and Images


Reply


7 Posts   7747 Views

Avatar
Aaron

Community Member, 63 Posts

9 June 2008 at 4:32pm

Reposted because I kinda hijacked someone else's thread:

Just tried a different 2.2.1 > 2.2.2 upgrade method:
1. Make copy of current HTML directory (2.2.1).
2. Replace cms, jsparty, auth_openid and sapphire directories with those from the 2.2.2 download.
3. Run /db/build?flush=1 on frontend - OK
4. Go to CMS and click "Files and Images" tab (/admin/assets)
5. Fatal error: Class '' not found in W:\html\sapphire\filesystem\Folder.php on line 104
I have checked this file and there is no line 104. It's like 70 lines long.
Problem does not occur when I do a fresh install using the very same archive.
Anyone experience something like this?
Could incompatible code be the culprit for such an error (I have two custom page types, one of which has various File and Image upload code)

Avatar
nomen

Community Member, 52 Posts

9 June 2008 at 10:41pm

Edited: 09/06/2008 10:41pm

Hi Aaron:

Did you have any problems flush-ing? Did you have created new classes in the project?

Excuse me for answering you making a question but I wrote [url=http://www.silverstripe.com/site-builders-forum/flat/82402/]this[/url] post and nobody else seems to have the same problem... i´m very confused... all my new page types are dissapeared...

Avatar
Aaron

Community Member, 63 Posts

9 June 2008 at 10:51pm

Hi nomen,
Just checked - no problem with db/build?flush=1.
However, doing a normal flush in the admin gives a page cannot be displayed error.
My page types seem to be there, so it doesn't look like our problems are related.

Avatar
sonicparke

74 Posts

27 June 2008 at 3:59pm

I'm having this exact same problem now. I upgraded from 2.2.0 to 2.2.2 and now I'm getting this error. I tried a fresh install but I obviously have to import the old DB and Assets and theme. Still getting the same error.

I think I'm going to try to roll back to 2.2.1 and see if that gets me up and running for now.

Is there anyone out there that has figured out how to fix this yet?

Avatar
hellohector

9 Posts

5 July 2008 at 11:05pm

I had the same problem upon upgrading to 2.2.2

Has this been fixed yet?

Avatar
Sam

Administrator, 685 Posts

7 July 2008 at 1:38pm

It looks like this problem is caused by some values of File.ClassName in the database have been cleared out.

Can you look in the File table in your database and see which rows don't have a ClassName value set? Do you know what the values would have been previously? Do you have a backup of your database?

Avatar
Double-A-Ron

Community Member, 604 Posts

7 July 2008 at 2:20pm

I ended up getting around this by doing a complete re-install, overwriting mysite and themes, then doing db/build/flush=1

Obviously not ideal for an existing site with existing data. But I was early stages when this happened for me. (I am the "Aaron" who started this thread)

Cheers
Aaron