Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Image gallery issue - blank page being displayed


Reply

5 Posts   2064 Views

Avatar
Fabie

10 June 2008 at 5:37pm Community Member, 28 Posts

Hi all,

I have been experiencing problems with the image gallery, more specifically getting a totally blank page when I am trying to view the 5th page of a specific Gallery page.

http://www.viphotographer.com/children-photographer/ this is the entry page and when you click at the bottom on page 5 of the gallery you get this: http://www.viphotographer.com/children-photographer/?start=32

This only seems to be happening on this very specific page. I have already tried to start from scratch and recreate the page, to no avail.

Any user having experienced this? Any idea what it would be coming from?

Thanks!

Avatar
Willr

10 June 2008 at 5:55pm Forum Moderator, 5511 Posts

try and set the site into dev mode by adding Director::set_environment_type("dev") in the mysite/_config.php file. This will hopefully give you a better error message then just a blank page!. Make sure you dont leave it in dev mode if its on that live server as it will output error messages which might contain your database details

Avatar
Fabie

11 June 2008 at 11:04am Community Member, 28 Posts

Will do that thanks!

In the meantime I have noticed that if .jpg images are written with a capital (JPG) extension and/or with a file name in capitals they do not display.

Avatar
Willr

11 June 2008 at 11:08am (Last edited: 11 June 2008 11:19am), Forum Moderator, 5511 Posts

Yes a few people have raised this issue, I will make it a bug ticket.

Edit: Ok I couldnt see this as a old ticket so Ive made a new one for it and assigned it to Romain (the gallery module maintainer) - http://open.silverstripe.com/ticket/2572

Avatar
Fabie

11 June 2008 at 1:52pm Community Member, 28 Posts

Thank you very much :)