Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

iFrame in Popup


Reply


3 Posts   1276 Views

Avatar
UncleCheese

Forum Moderator, 4094 Posts

13 June 2008 at 7:37am

Edited: 13/06/2008 7:37am

I think I messed something up pretty bad. I used to have an iframe upload working perfectly in my CTF popup. After saving, the message "You can add files ones you have saved for the first time" would disappear and I'd get the FileIFrameField immediately. Now I have to close the window and reopen it with the edit button to get it to show.

Any idea what I might have done? It looks as if the form is submitting via ajax so it never reloads. Maybe before it wasn't?

Avatar
Ingo

Forum Moderator, 801 Posts

21 June 2008 at 6:39pm

hm, are you using trunk or daily builds? if not, can you reproduce this error with the latest daily builds? the complextablefield javascript hasn't changed in a while as far as i can tell, should still submit without ajax

Avatar
UncleCheese

Forum Moderator, 4094 Posts

24 June 2008 at 1:27am

Not sure what happened here, Ingo. Thanks for your reply. I ended up just re-uploading the sapphire directory and it fixed the problem. I did manage to hack a loading graphic into the iFrameFileField, however. I think that would be a great idea for the next release!

While I have you here, speaking of ajax posts, I noticed that on some of my sites, page comments submit with ajax and on others, they don't. Is there any reason for this?