Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Problem when changing WAMP "Documentroot" setting in Apache httpd file


Reply


3 Posts   3028 Views

Avatar
Blairos

Community Member, 7 Posts

14 June 2008 at 8:00am

Hi There

This may be a ridiculously easy fix, but sometimes you cant see the forest for the trees :-)

I have installed SS 2.2.2 onto a PC running WAMP.

Everything works great, CMS etc... but when the time arrives for me to "go-live", I want my users to access a root URL, not a URL, then subfolder (such as "silverstripe-v2.2.2")

I have read the documentation for SS, and it advises on how to change the Documentroot setting, and associated Directory, to "silverstripe-v2.2.2"

Once I update the httpd file, and restart Apache, I type in "localhost", and get a file not found error...

Hopefully someone has had the same issue, and a simple fix ensues...

Thanks in advance

Avatar
simon_w

Forum Moderator, 474 Posts

14 June 2008 at 8:41am

This is probably due to a RewriteBase in .htaccess.

Edit .htaccess and change the line:

RewriteBase /silverstripe-v2.2.2/


to

RewriteBase /

Also, the document root setting must be a full path to the folder.

Avatar
Blairos

Community Member, 7 Posts

14 June 2008 at 9:19am

Thanks for that - I forgot to menion I was using the full path as the documentation advised...

In any case, your suggestion worked!

Thanks!