Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Setting up External Authentication and getting error


Reply


4 Posts   1223 Views

Avatar
MKayHavoc

Community Member, 33 Posts

24 June 2008 at 8:40pm

Hi,

I'm following the instructions to set up the auth_external module. So i've copied auth_external to the root of my site, copied the _config.ldap file from the docs folder and renamed it to _config.php. That's as far as I've got and I get this message:

Fatal error: Declaration of ExternalAuthenticator::authenticate() must be compatible with that of Authenticator::authenticate() in /webdata/sites/staff/auth_external/code/ExternalAuthenticator.php on line 458

Can anyone help?

Thanks

Ryan

Avatar
MKayHavoc

Community Member, 33 Posts

25 June 2008 at 9:16pm

Hasn't anyone else had this problem? Really need to fix this. :-(

Avatar
MKayHavoc

Community Member, 33 Posts

27 June 2008 at 8:11pm

Has anyone actually got this extension working?

Avatar
MKayHavoc

Community Member, 33 Posts

1 July 2008 at 10:00pm

OK, i finally made some progress with this problem. On line 323 of ExternalAuthentictor.php it says:

public static function authenticate(array $RAW_data, Form $form = null) {

If it's not set to:

public static function authenticate($RAW_data, Form $form = null) {

It throws the error.

Anyway. I don't seem to be able to authenticate against my AD server. I know my details are correct because I use them for other apps.

How can I attach a debugger log file or something to see exactly were things are going wrong?