Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Installed but cannot login, just refreshes


Reply


6 Posts   1685 Views

Avatar
darkhouse

Community Member, 12 Posts

30 June 2008 at 8:04pm

As I see many people have, I too am unable to login after installation. When I try to login, it just refreshes, no errors, nothing. I have tried my own custom username and password, I have tried the default. I have tried removing the entire site and database and reinstalling. I have tried using incorrect info to see if I get any errors, again nothing. I've tried using the default theme, I've tried starting with no theme. I've flushed everything I don't know how many times, I've deleted all my cookies. I even saw one person say it was an issue with their firewall, so I disabled mine. I've scoured the internet and these forums, I haven't come across a concrete solution that works for everyone.

The pages in the default theme, like Home, About Us and Contact Us, they all work, so I know the system is installed and working. I just can't log in.

I REALLY want to get using this CMS, I was about to write my own because of how disappointing Joomla and Drupal are, and then I found SilverStripe. It seems as though it's close to perfect, it works like how I was intending on writing it, only now I don't have to, (though I'm sure this works far better than what I could write)... if I could only log in!

Please help. Thank you.

Avatar
Willr

Forum Moderator, 5513 Posts

30 June 2008 at 8:28pm

If you have PHPMyadmin installed then I suggest you login to that and check your 'Member' table if there is any members in there.

You can also add this to your mysite/_config.php file which will 'hard code' a member for the site

Security::setDefaultAdmin("YourNewUsername","YourNewPassword");

Then visit yoursite.com/admin?flush=1 and login with those details.

Avatar
darkhouse

Community Member, 12 Posts

30 June 2008 at 8:41pm

Thanks, however that didn't help. The Member table has the record, and I added the line you gave me.

The page is here, [url]www.darkhousemedia.com/projects/envirolet/admin[/url] and the username/password is admin/password

Avatar
Willr

Forum Moderator, 5513 Posts

30 June 2008 at 8:53pm

Seems strange, eg theres no error message in the form, even if you submit it with a wrong account.. I dont know if this would effect anything inside SS but running it within a sub directory of the sub directory? maybe somethings not working because of that?

Are you using the stable version (2.2.2?)

Avatar
darkhouse

Community Member, 12 Posts

30 June 2008 at 10:00pm

Exactly. I don't see how the subdirectory issue would be the reason, since all the pages load fine, just forms don't submit.

I am using the latest stable version, 2.2.2

I'll talk to my server tech, maybe it's something on our server, but I've never experienced this with any other website.

Avatar
darkhouse

Community Member, 12 Posts

2 July 2008 at 7:23am

Bah, it turns out the problem was somebody added this line to my master .htaccess file:

php_value session.save_path /path/that/doesnt/exist

and that was throwing the whole thing off. That explains why I've never experienced that with any other site, as it was only affecting my domain.

Sorry for the confusion and thanks for the help.