Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

installation woes on e-smith server 7.3


Reply

3 Posts   1434 Views

Avatar
PhilT

9 July 2008 at 1:21am (Last edited: 10 July 2008 10:59pm), Community Member, 2 Posts

Problem

mod_rewrite doesn't appear to be working. Make sure:

* mod_rewrite is enabled in your httpd.conf
* AllowOverride is enabled for the current path.

Please check these options, then refresh this page.If you believe that your configuration is correct, click here to proceed anyway.

I proceed and then, I get a message saying everything was successfuly installed, but then this:

"The requested URL /silver/home/successfullyinstalled was not found on this server."

I'm sure mod_rewrite is enabled, here is an excerpt from /etc/httpd/conf/httpd.conf
LoadModule rewrite_module modules/mod_rewrite.so

However, I have tested the Alice and Bob example http://www.workingwith.me.uk/articles/scripting/mod_rewrite. (the redirection is not working in the example isn't working).

I'm new to theLinux environment, but have managed this far.. I'd appreciate some help with this.

PHP 5.1.2
MySQL 4.1.20

The server runs Apache

This is my .htaccess

### SILVERSTRIPE START ###
RewriteEngine On
RewriteBase /silver

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]

### SILVERSTRIPE END ###


All help appreciated.

Avatar
PhilT

10 July 2008 at 11:01pm Community Member, 2 Posts

Come on guys, this question can't be that difficult for such a capable group of developer's.

I'm stuck!

Avatar
Sam

14 July 2008 at 5:26pm Administrator, 685 Posts

Did you double check those two points?

* mod_rewrite is enabled in your httpd.conf, ie, your apache config.
* AllowOverride is enabled for the current path. This will also be in your apache config.

If you're on a shared server you will need to ask the administrator