Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Security tab problem


Reply

6 Posts   3411 Views

Avatar
Pixel

11 July 2008 at 12:29am (Last edited: 18 July 2008 1:11am), Community Member, 78 Posts

I need to set up some administrators however when I click on the Security tab i get this error

Fatal error: Access to undeclared static property: ViewableData::$db in /var/www/vhosts/xxxxxxxx.co.uk/httpdocs/sapphire/core/Object.php(324) : eval()'d code on line 1

I also get the same error for forum members and mailing lists within Security

The site is almost ready to go live and this is a big issue that i need to resolve soon - how can i fix it.

Avatar
efraimalexander

12 July 2008 at 1:45am Community Member, 3 Posts

I am seeing the same error. I tried a fresh install of SilerStripe 2.2.2 but the bug is persistant. Is there any specific requirements on the server side to run the security section. I am using an Ubuntu server.
Need more details in server? Any ideas on what's wrong? Thanks.

Avatar
efraimalexander

12 July 2008 at 2:44am Community Member, 3 Posts

I did two things.
First I increased the memory_limit in /etc/php5/php.ini from 20M to 32M. This was recommended by the Silverstripe install page.
This did not make the Security tab in my 2.2.2 site work.
Then I installed Silverstripe 2.0.2 sr2 the same way, on the same server.
The security tab in 2.0.2 works fine now.

A bit closer..:-)

Avatar
efraimalexander

13 July 2008 at 8:35am (Last edited: 13 July 2008 8:36am), Community Member, 3 Posts

Seem to be discussing this with myself :-))
Just like to add; the bug(?) is also affecting the possibility to produce Reports.
I am receiving this on a blank page:

Fatal error: Class 'Report_StatsReport' not found in /var/www/mysite/cms/code/ReportAdmin.php on line 70

So two problems that perhaps are related.

Avatar
Sam

14 July 2008 at 4:04pm Administrator, 679 Posts

This bug only affects PHP 5.1.2. Would it be possible to upgrade PHP to 5.2.x?

Avatar
mnemo

1 August 2008 at 7:31am Community Member, 6 Posts

I'm also getting this error:

/var/www/vhosts/domain.co.uk/httpdocs/sapphire/core/Object.php(324) : eval()'d code on line 1

The php version is 5.1.2, I'm on a VPS and my hosts are unable to upgrade to 5.2.*, something to do with a conflict with the plesk control panel.

I'm I able to get Silverstripe working with php 5.1.2?