Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Error - No input file specified.


Reply


2 Posts   2555 Views

Avatar
brink668

Community Member, 4 Posts

18 July 2008 at 10:12am

Hi, I had SilverStripe working but it stopped working after a few hours. So I reinstalled it on my host and it installed but when i deleted the Installation files as following the directions i now receive this message:

No input file specified.

MY HOST:
HostGator

MY SITE:
http://www.gamersreloaded.net/site/

MY HTACCESS:
### SILVERSTRIPE START ###
RewriteEngine On
RewriteBase /site

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
### SILVERSTRIPE END ###
AddHandler application/x-httpd-php .php

I also had 5php handler in before that handler

Can someone help me out!

Avatar
brink668

Community Member, 4 Posts

18 July 2008 at 10:15am

Edited: 18/07/2008 10:16am

Ok... Now i got this to work and Honestly please this is confusing but i just tried something and it happened to work.

my SilverStripe install sits in a folder in the Public_html called SITE

I deleted and recreated the HTACCESS which was in the folder Public_HTML and all seems to be working now....