Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

BlackCandy has invalid HTML


Reply

4 Posts   1536 Views

Avatar
Sigurd

22 May 2007 at 5:26pm (Last edited: 22 May 2007 5:26pm), Forum Moderator, 628 Posts

Will, the BlackCandy's mysite/templates/page.ss contains the following code. There is one more </div>'s than needed and it prevents the template running in firefox. I'm removing the one found immediatley after $Layout it seems to work... can you republish this? :)

<div id="Container" class="typography">
<div id="Header">
<h1>Your Site Name</h1>
<p>your site&apos;s tagline here</p>

<% if Menu(1) %>
<% include Menu1 %>
<% end_if %>
</div>

<div class="br"><!-- --></div>

$Layout

</div>

<div class="br"><!-- --></div>

<% include Footer %>

</div>

Avatar
Willr

22 May 2007 at 8:04pm Forum Moderator, 5511 Posts

sorry sig, Its not that huge of a problem.. That div is being opened in Page.ss in the layout folder. I had changed it a while back and just forgot to tidy up. If a SS template has invalid html you usually get a big red XML error box.

So its not invalid its just bad coding which needs to be fixed anyway. So I will get onto it when I have 2 seconds. That and a fix to the images.. Some use png instead of gif and you can notice a slight color mismatch on some monitors, This has been fixed but havent updated the SS zip (The new SS demo site that I am working on has most of the fixs I am talking about)

Cheers,
Will

Avatar
Sigurd

22 May 2007 at 10:39pm Forum Moderator, 628 Posts

Hmm, I see what you're saying but I am getting this problem to happen very reliably during my time documenting the forum installation process... See http://doc.silverstripe.com/doku.php?id=forum-installation

Avatar
Willr

23 May 2007 at 2:40pm Forum Moderator, 5511 Posts

Sig, zip has been updated with the fix to page.ss and a couple other fixs with transparent gifs replacing a couple of pngs. Let me know of any issues