Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

No user created during install


Reply

6 Posts   2171 Views

Avatar
manafta

23 May 2007 at 7:19am Community Member, 7 Posts

Hi,

After the install I get an HTTP authetication window.

The install script created database tables, _config.php and .htaccess. But in the database no user record has been added. So nothing works.

I am using Silverstripe 2.0.1. My provider runs PHP 5.2.1 as CGI under Apache. According to the PHP manual HTTP authetication cannot work under CGI.

Is there a way to get Silverstripe running as CGI?

Avatar
Sigurd

23 May 2007 at 9:08am Forum Moderator, 628 Posts

If you add to mysite/_config.php:

Security::setDefaultAdmin('admin','password);

Then it will force that login to function, so you can get in. That might progress you, hopefully to the working system.

You might need to view <silverstripeUrl> /db/build if the site isn't working straight off.

Avatar
manafta

24 May 2007 at 5:30am Community Member, 7 Posts

Setting a default admin didn't do anything. The only pages I can access are the ones in the webroot, which are real files. For all other pages I get the authentication window, not just for /admin/.

Avatar
Sigurd

24 May 2007 at 12:42pm Forum Moderator, 628 Posts

So you are saying that it wouldn't permit "admin" and "password" to log you in even if with this in your _config.php ??

Security::setDefaultAdmin('admin','password);

Because that's odd!

Is your hostname something like "test" ?

Avatar
manafta

25 May 2007 at 11:32pm Community Member, 7 Posts

The subdomain was called "test" . After changing the subdomain name it is working normally :-)

Avatar
Sigurd

26 May 2007 at 9:06am Forum Moderator, 628 Posts

yeah there is some hard-coded stuff to do with 'test' hostname that will be improved for 2.0.2