Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

Deleting security groups - users still exist


Reply


3 Posts   1563 Views

Avatar
thejackel

Community Member, 33 Posts

31 July 2008 at 10:06pm

Hello,

I've created some user groups in the security section.

I added some users to these groups and all was working well.

I decided to delete the groups (thinking it would also delete the members of those groups). This worked fine...

The problem is, i have added some new groups and tried to add the same members i had in previously but the system kicks out an error and won't let me add the user?!

Upon checking the database I've found that the users which were in my deleted groups, still exist in the member table. Shouldn't they have been deleted??

Does anybody know why this is happening and if its a bug?

Thanks in advance

Avatar
Liam

Community Member, 470 Posts

1 August 2008 at 5:13am

As far as I know, that's how the system was built - to never fully delete members, only delete them from groups.

I remember reading a topic on this a while ago, and don't remember all the details and the reasoning.

Avatar
thejackel

Community Member, 33 Posts

1 August 2008 at 8:38pm

Edited: 01/08/2008 8:39pm

Hi Lee,

thanks for your reply.

How blooming strange is that though?

How do you delete members then? Thats bizzare, the members are kept in the table but theirs no way of getting to them.

Also, after deleting the groups I noticed when I go into the access tab for a page, the groups still appear in the dropdown list??

They should have been removed, shouldn't they?

So let me get this straight, the groups functionality works ok if you never want to delete users or groups?

Come on guys, can we see this issue looked at and fixed for the next release? Please.

Ta