Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo

Unable to successfully install

Go to End

3 Posts   1274 Views


Community Member, 2 Posts

4 August 2008 at 11:18pm

I've just downloaded Silverstripe yesterday and tried installing it to my website

Once all parameters are put into the installation fields, The following page comes up:
Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating /home/balraj/public_html/mysite/_config.php
Creating '.htaccess' file...
Creating /home/balraj/public_html/.htaccess
Building database schema...

After this there is seems odd that there is no success or failure message.

When browsing to the website, I get the following:
The requested page couldn't be found.

Checking MySQL in my cPanel, I can see that the database has 54 tables in it and all bar one of the tables contains 1 record of data.

Am I missing something?

Kind regars,


Forum Moderator, 5521 Posts

5 August 2008 at 2:45pm

try logging into the cms - go to and enter your details. Is there a homepage? its possible the Database builder died while creating the pages so you might have to create a 'Home' page in the CMS


Community Member, 2 Posts

9 August 2008 at 2:07pm

Thank you, that worked. However I was unable to login in and realised upon re-install that I had only put "admin" as the admin username instead of a full email address - this caused it to fail. Putting an email address caused the installation to proceed further but there was still no home page created. However, I am in the CMS admin screen and hopefully can get around that.

Many thanks for your help.

Kind regards,