Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Archive /

Our old forums are still available as a read-only archive.

Moderators: martimiz, Sean, biapar, Willr, Ingo, simon_w

bulding my first website


Go to End
Reply


13 Posts   4985 Views

Avatar
acronum

Community Member, 15 Posts

14 August 2008 at 5:09pm

Hi all,

I have just started with silverstripe, downloaded it two days ago and i have been busy playing with it. I uploaded the base website (blackcandy) then went on to build the website.

A few problems;
I cant change the name of the website (it never asked me to enter a name).
I cant access any of the forums and comes up with and error message for the script.
when trying to install the forum... it stayed on the same page for over an hour... ended up deleting the entire silverstripe system and i now use a complete one that a friend made on a different computer.

this is just starting to be a pain in the A and i am thinking of scrapping silverstripe altogether now.

Avatar
acronum

Community Member, 15 Posts

14 August 2008 at 5:18pm

http://www.youths-empowered.com/silverstripe-v2.2.2/silverstripe-v2.2.2/

this is the URL of the website, i would like to change the bit in the blue, and the forums to work.

Avatar
Josh

SilverStripe Developer, 65 Posts

14 August 2008 at 5:35pm

Hi Acronum,

I would suggest using a local server before uploading to an online one. This way you can look at the php-error log easily and develop things faster than a hosted site. Then once your site is ready upload it to the real server. If you are on Mac download MAMP, on windows download WAMP.

To change the look of the site, just edit the theme templates and css files.

The forums seem to be working okay?

Avatar
acronum

Community Member, 15 Posts

14 August 2008 at 5:37pm

this is what i get when i try to open a forum;
XML Parsing Error: junk after document element
Location: http://www.youths-empowered.com/silverstripe-v2.2.2/silverstripe-v2.2.2/general-discussion/
Line Number 2, Column 1:<b>Notice</b>: Controller::currentController() is deprecated. Use Controller::curr() instead. in <b>/home/.leif/acronum/youths-empowered.com/silverstripe-v2.2.2/silverstripe-v2.2.2/sapphire/core/control/Controller.php</b> on line <b>367</b><br />
^

Avatar
Josh

SilverStripe Developer, 65 Posts

14 August 2008 at 5:38pm

Add ContentNegotiator::disable(); to your mysite/_config.php file and see what happens.

Avatar
acronum

Community Member, 15 Posts

14 August 2008 at 5:44pm

now i get;

Parse error: syntax error, unexpected T_GLOBAL in /home/.leif/acronum/youths-empowered.com/silverstripe-v2.2.2/silverstripe-v2.2.2/mysite/_config.php on line 3

Avatar
Josh

SilverStripe Developer, 65 Posts

14 August 2008 at 5:49pm

Start checking your php error log and you may find what is going wrong here.

It is best to have some knowledge of Html, Css and a little Php when developing with SilverStripe.

Cheers

Avatar
acronum

Community Member, 15 Posts

14 August 2008 at 5:51pm

i seem to have got something to work... i originally put it at the top, now i put that code snippet at the bottom and i get to veiw the page and post threads and replys etc, and this shows up at the top;

Notice: Controller::currentController() is deprecated. Use Controller::curr() instead. in /home/.leif/acronum/youths-empowered.com/silverstripe-v2.2.2/silverstripe-v2.2.2/sapphire/core/control/Controller.php on line 367

Debug (line 118 of BBCodeParser.php): Welcome to the General Discussion forum!

Go to Top